X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I want Firefox to open to my iGoogle page when ever I open Firefox. How do I do that?

Posted

Firefox used to open with my iGoogle homepage when I opened it up. I have created my personal homepage and that's what I want when I open. Suddenly, it started opening with the last page I was on in a previous session. When I noticed this, I made sure to close every page that was open before I signed off Firefox. Still, it will open with the last page of the previous session.

All I want is for Firefox to open my iGoogle page every time, as my homepage, when I go online with Firefox. How do I do that? I think I've checked some box I didn't intend to but I cannot find what it is. Is this something I do through Google? If so, sorry, but this is annoying and wasting a lot of my time figuring out how to make my life 'easier.' thanks.

Chosen solution

Please do the following.

  • Go to the site you want to set as your homepage.

  • Click the Firefox button, go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.


If this suggestion resolves the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

Read this answer in context 20

Additional System Details

This happened

Every time Firefox opened

This started when...

recently

Installed Plug-ins

  • 1.9.0009.1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Default Plug-in
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • 4.0.60531.0
  • Google Updater pluginhttp://pack.google.com/
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18 GTB7.1

More Information

Xircal 334 solutions 3835 answers

Chosen Solution

Please do the following.

  • Go to the site you want to set as your homepage.

  • Click the Firefox button, go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.


If this suggestion resolves the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

Question owner

OK, did that. Then I opened a new page and it came up, again, with the last page Firefox had on, not my homepage as I had indicated in "use current". Maybe I have to restart before this is effective. I'll try that. Thank you.

Xircal 334 solutions 3835 answers

Are you sure it says "Show My home page" in the top menu and not "Show my windows and tabs from last time"?

Question owner

Thank you! That did it. You're a genius!

Xircal 334 solutions 3835 answers

You're welcome.

ebcutler 0 solutions 3 answers

I have the same problem. I have followed every one of these steps numerous times. Are there check boxes in other tabs of "Tools/Options" that need to be checked or unchecked. This is hugely irritating. It does not happen on IE. The problem is definitely Firefox.

Sandlecat 0 solutions 1 answers

None of these suggestions work. It continually opens imesh as my homepage, which I never set in the first place. It is extremely frustrating. How do I get igoogle to be my permanent homepage whenever I reopen Firefox???

Modified by Sandlecat

jscher2000
  • Top 10 Contributor
2387 solutions 21097 answers

Hi Sandlecat, the imesh problem is related to an add-on. Please see these past threads for suggestions on how to remove it:

"imesh" keeps hijacking my home page. Every time I change it , imesh changes it back to the imesh search page. How can I get rid of it?

How to stop Imesh from changing my homepage automatically?

i need to remove imesh

Do any of those help? If not, you could start a new question; it's hard to get personal help in a "Solved" thread like this one.

https://support.mozilla.org/en-US/questions/new