Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I block Buzzdock Ad from popping up every time I do a search? There does not appear to be anything to grab for Ad Blocker.


I do a search and results are displayed. I select something and in the time it takes to click ok on a searched item a Buzzdock Ad box appears at the top of the screen and your ok selects an ad in the Buzzdock Ad box. How do I add this to Ad Blocker as I cannot find any link to block? Thanks

Modified by msteinbach

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.60531.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object


  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Do not know how to troubleshoot this issue

mylifeforthecorps77 0 solutions 1 answers

I suggest contacting their customer support directly. I searched for Buzzdock in Google and I saw that they had a Support Page so that might be worth a shot. I hope this helps!

Izu_uzI 0 solutions 1 answers

Helpful Reply

I had this problem too after updating to Firefox 6. Every Google search was preceeded by that annoying Buzzdock thing, appearing just in time to get clicked instead of the first result.

This is in fact caused by a Firefox Add-on called "Yontoo Layer" which is part of PageRage, so you just need to uninstall this one and the problem is solved:

Go in the "Firefox" (or "Tools") menu; Click on "Add-ons"; Select "Extensions" on the left; Search for "Yontoo Layer" on the right; Click on its "Remove" button; Restart Firefox.

I just did a Firefox fresh install on a VM, and this add-on wasn't here. So I don't really know how we all got it. :(

Modified by Izu_uzI

valkerine 0 solutions 4 answers

I have this problem too. If you didn't install buzzdock, then someone must have downloaded either PageRage or other programs that are affiliated with Yontoo Layers. Bascially some programs are bundled with other programs, it is the users responsibility to check if they wanted the program installed. Before you install the program there a few boxes that are checked that includes programs such as Buzzdock or DropDwonDeals.

If you need to disable Buzzdock go here and find out how itl explains how to disable or uninstall it. The best way is to just disable it the program.

How to remove Buzzdock:


Join SUPERPOINTS today to earn cash!

Go here for invites codes updated daily! http://adf.ly/3UKke

Modified by valkerine

DiegoXCI 0 solutions 1 answers

Im not sure about firefox, but this is how i removed mine from Google chrome.

Go to Youtube.com Sign in Go to -Inbox Go all the way down and should see "Disable Buzzdock"

This should disable buzzdock ads everytime you do a google search.

valkerine 0 solutions 4 answers

Buzzdock also has the dock on over 40 Web domains. Im not going to list it here.

But you can check it out here: http://adf.ly/1027680/how-to-remove-buzzdock-from-google

Plus I also added a video on how to disable Buzzdock on all web domains.

valkerine 0 solutions 4 answers

If anyone have issues removing Buzzdock please feel free to go here on how to remove Buzzdock from all web domains.

How to remove Buzzdock: http://adf.ly/1027680/how-to-remove-buzzdock-from-google

Modified by valkerine

valkerine 0 solutions 4 answers

You can go here and check out how to Disable Buzzdock and the entire Yontoo platform that supports Buzzdock and other applications:

lesspalding 0 solutions 1 answers

Helpful Reply

I solved my problem by removing "yontoo" from add or remove programs

domensional 0 solutions 1 answers

Firefox removal: in the top left corner click on firefox, click on add-ons. Remove or disable Yontoo. Finished.

Modified by domensional