Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

HOW DO I GET RID OF THE BLUE FIREFOX DRIVER ICON NOW ON MY DESKTOP? HOW DO I MAKE FIREFOX GO DIRECTLY TO MY HOMEPAGE WITHOUT FIRST HAVING AN APPLICATION FOLDER WINDOW APPEAR ON MY DESKTOP?

  • 5 replies
  • 10 have this problem
  • 4801 views
  • Last reply by sehar_03

more options

I just downloaded Firefox to my Mac. Now there is a permanent icon of Firefox on my desktop. Not the Firefox icon though, it is a blue diskdrive icon with a white fox on it.

Also, when I open Firefox a window opens up that has another firefox icon with an arrow beside it pointing to my Applications folder. This happens everytime I open firefox.

How do I get rid of these?

Chosen solution

Hi there,

I had exactly the same problem as you and it really annoyed me, so I started to do some experimenting,

Go to your desktop screen and eject the Firefox icon at the top (If you need to quit Firefox, then quit it first or a prompt will come up, either ways fine). Also, at the bottom of your dock get rid of the Firefox icon too (you just drag the icon up and it should disappear),

Then, type in "Applications" in the search bar on the top right of the corner of the screen, and click on your applications,

There should be that same Firefox driver icon there that was on your desktop, click on it (If there's one that says "Firefox Alias" or "Firefox 2" just ignore it. Go for the original one). It should take you into a sub folder with the Firefox dock icon (orange and blue ball) and an folder with no name in it,

Click on the orange and blue ball, and it should now appear in your dock,

Firefox should open without any application/driver icons appearing,

Move it around to where you want it to be positioned,

And just to double check, quit Firefox, and any other browser you have open, and click on the blue and orange icon again to see if any more drivers/application folders appear...

And that's it,

I hope it works for you :)

Read this answer in context 👍 0

All Replies (5)

more options

Installing Firefox on Mac

https://support.mozilla.com/en-US/kb/Installing%20Firefox%20on%20Mac

Check and tell if its working.

more options

Short answer: you have to eject the disk drive icon.

more options

Hello and thank you for your help. I did eject it but it shows up again every time I open up Firefox. Do you know how to get rid of it permanently? Thank you again.

more options

Hello, Thank you for your help. It was incredibly thorough. However it did not permanently solve the problem. It all appears on the desktop again every time I open up Firefox. Do you know how to stop that from happening? Thank you again.

more options

Chosen Solution

Hi there,

I had exactly the same problem as you and it really annoyed me, so I started to do some experimenting,

Go to your desktop screen and eject the Firefox icon at the top (If you need to quit Firefox, then quit it first or a prompt will come up, either ways fine). Also, at the bottom of your dock get rid of the Firefox icon too (you just drag the icon up and it should disappear),

Then, type in "Applications" in the search bar on the top right of the corner of the screen, and click on your applications,

There should be that same Firefox driver icon there that was on your desktop, click on it (If there's one that says "Firefox Alias" or "Firefox 2" just ignore it. Go for the original one). It should take you into a sub folder with the Firefox dock icon (orange and blue ball) and an folder with no name in it,

Click on the orange and blue ball, and it should now appear in your dock,

Firefox should open without any application/driver icons appearing,

Move it around to where you want it to be positioned,

And just to double check, quit Firefox, and any other browser you have open, and click on the blue and orange icon again to see if any more drivers/application folders appear...

And that's it,

I hope it works for you :)