X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Coupons.com plug in

Posted

I recently upgraded my mac to the Lion OS. Now my coupons.com plug in won't work. Firefox doesn't recognize that I have downloaded the software. Coupons.com keeps telling me to install it. Or it freezes up my firefox. What should I do?????? I must have my coupons! Ive tested in safari too. Not working. Same errors!!!

Additional System Details

Sites Affected

http://Coupons.com

Installed Plug-ins

Application

  • User Agent: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5

More Information

serpico7456 0 solutions 1 answers

Helpful Reply

coupons.com is notorious for having problems when updates come out for Mac OS X. That said, they are also pretty responsive to questions if you *call* their support line and leave a message (650) 605-4600. They recently told me that everyone should be able to print using 10.7 Lion using firefox. They know there is a problem with Safari and they are working to fix it. If you can’t print using firefox then call them–they usually call back the same day or next.

BetsyR 1 solutions 15 answers

This problem is not just specific to Mac. I'm on Windows, and after my last FF update, I can't use the Coupons.com printer anymore. But it works fine with Internet Explorer. So for now I'm stuck with using IE for printing coupons.  :( ...If you look in the Mozilla forums you'll see that other people are having this problem and many are using Windows, not just Mac.

Windows users are suffering with this along with you.  :(  :(

Modified by BetsyR

StrWlf 0 solutions 1 answers

Yes, windows users are indeed suffering and it took me many diagnostics, scans and downloads to nowhere before I got a response from Coupons.com. I did all they suggested and the only thing that really worked for me was to use IE8 which is definitely not my favorite browser. I have found that for other things such as updates and help for windows I must use, or have installed, IE8 or they will not be accessible.

It is nice to know that I am not alone and I look forward the a FF update or fix much sooner than any help from Windows or Coupons.com

Modified by StrWlf