Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why are the location bar keyword options ignored in favor of http://search5.comcast.com/?cat=dnsr&con=ds&url=

  • 4 replies
  • 6 have this problem
  • 5 views
  • Last reply by cor-el

more options

Why are the location bar keyword options ignored in favor of http://search5.comcast.com/?cat=dnsr&con=ds&url= ?

Somehow my location bar search feature has defaulted to a comcast url as noted above.

I have changed the url as directed in help and this is reflected in about:config, but location bar search still reverts to comcast.

I tried toggle it off altogether, again reflected in about:config, but still I get the comcast search function.

Why are the location bar keyword options ignored in favor of http://search5.comcast.com/?cat=dnsr&con=ds&url= ? Somehow my location bar search feature has defaulted to a comcast url as noted above. I have changed the url as directed in help and this is reflected in about:config, but location bar search still reverts to comcast. I tried toggle it off altogether, again reflected in about:config, but still I get the comcast search function.

Chosen solution

You have an ISP that automatically redirects you to a search page if a DNS look up fails. That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.

You can click the link "Disable this error service":


Read this answer in context 👍 0

All Replies (4)

more options

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. Now do this:

-> go to View Menu -> Toolbars -> unselect All Unwanted toolbars

-> go to Tools Menu -> Clear Recent History -> Time range to clear: select EVERYTHING -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache -> click Clear Now

-> go to Tools Menu -> Options -> General -> When Firefox starts : select "Show My Home Page" -> Type the address of the website which you want to be your HomePage e.g. http://www.google.com -> place Checkmark on "Show the Downloads window when downloading a file" -> select Radio Button option2 "Always ask me where to save files"

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites

-> go to Tools Menu -> Options -> Advanced -> Network -> Offline Storage (Cache): click Clear Now button

-> Click OK on Options window

-> click the Favicon on SearchBar -> click Manage Search Engines -> select all Unwanted Search Engines and click Remove -> click OK

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious Extensions (Add-ons) -> Restart Firefox

You can enable your Known & Trustworthy Add-ons later. Check and tell if its working.

more options

Chosen Solution

You have an ISP that automatically redirects you to a search page if a DNS look up fails. That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.

You can click the link "Disable this error service":


more options

Amazing! Comcast assumed control of my browser location search function.! I am so tired of this company! I'll be switching as soon as Cruzio (95060) handles phone service. Thanks for the concise & accurate answer.

more options

You're welcome