Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Java is not being detected in firefox 5.0.1

  • 28 replies
  • 81 have this problem
  • Last reply by AliceWyman

more options

For some reason Java stopped working when I turned on my computer this morning.

I've tried reinstalling Java, and Firefox, but nothing seems to work.

The java website isn't detecting my Java plugin on Firefox. IE works fine with java though.

All Replies (20)

more options

I've also done a complete clean install of Firefox, and it didn't help.

more options

Your More system details list shows that you have the Java plugin:

  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers

Do the Java test pages confirm that the Java plugin is working?

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

No, it does not detect java it says.

I tried starting and safe mode, and it still did not work =[ I even did a clean reinstall, and it didn't fix it. Could it be a registry problem?

more options

Does anyone else have this problem?

more options

Can i get some help with this?

more options

Do you see the Java plugin on the about:plugins page?

Do you have problem with other plugins?

more options

No java is the only plugin that I use, besides flash and flash works fine.

here's what it says in about:plugins

Java(TM) Platform SE 6 U26

   File: npjp2.dll
   Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers

MIME Type Description Suffixes application/x-java-applet Java Applet application/x-java-bean JavaBeans application/x-java-vm application/x-java-applet;version=1.1.1 application/x-java-bean;version=1.1.1 application/x-java-applet;version=1.1 application/x-java-bean;version=1.1 application/x-java-applet;version=1.2 application/x-java-bean;version=1.2 application/x-java-applet;version=1.1.3 application/x-java-bean;version=1.1.3 application/x-java-applet;version=1.1.2 application/x-java-bean;version=1.1.2 application/x-java-applet;version=1.3 application/x-java-bean;version=1.3 application/x-java-applet;version=1.2.2 application/x-java-bean;version=1.2.2 application/x-java-applet;version=1.2.1 application/x-java-bean;version=1.2.1 application/x-java-applet;version=1.3.1 application/x-java-bean;version=1.3.1 application/x-java-applet;version=1.4 application/x-java-bean;version=1.4 application/x-java-applet;version=1.4.1 application/x-java-bean;version=1.4.1 application/x-java-applet;version=1.4.2 application/x-java-bean;version=1.4.2 application/x-java-applet;version=1.5 application/x-java-bean;version=1.5 application/x-java-applet;version=1.6 application/x-java-bean;version=1.6 application/x-java-applet;jpi-version=1.6.0_26 application/x-java-bean;jpi-version=1.6.0_26

more options

That should make the Java plugin work.

You can try to change the Java settings:

  • Control Panel > Java > General tab > "Network Settings...": "Direct Connection" (enable)

more options

No luck. java website still says I do not have it installed.

I tried playing a java game as well, and it says java isn't install either.

for some reason firefox thinks it's not installed, but it works on IE.

more options

That is quite weird considering that the plugin shows as installed in Tools > Add-ons > Plugins and on the about:plugins page.

Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)


more options

That did not work either.

I've also tried reinstalling firefox, and deleted all the files aswell.

more options

Any other suggestions?

more options

Remove Skype extension This extension has been reported as causing various malfunctioning problems in Firefox. See this list of Blocked/Problematic Add-ons:

Uninstalling Add-ons

Cannot Uninstall an Add-on

Troubleshooting extensions and themes

After all that, see this - Using the Java plugin with Firefox

Check and tell if its working.

Modified by Hasan

more options

Skype isn't installed anymore, it was removed, and I did a clean reinstall of firefox, so all plugins were removed.

more options

Using the Java plugin with Firefox


Check and tell if its working.

more options

sorry for the late reply, i've been busy. but no it isn't working. I can't seem to get it to detect it.

more options

-> Create a New Profile as a test to check if your current profile is causing the problems.

-> Test Java in your New Profile

-> IF the New Profile works then you can recover your Bookmarks and Passwords from the Old Profile.

Check and tell if its working.

Modified by Hasan

more options

Maybe something here will help?

Something else to try is to update Java to the latest version from the Java Control Panel's Update tab. See

Modified by AliceWyman

more options

Doesn't seem to work, here's what i've tried so far.

Completely uninstalled both firefox, and java, and did a clean install

Making a new profile for firefox

Reinstalling java several times

it's definitely enabled, but it just doesn't detect it.

more options

Do you have a 32 bit system or a 64 bit system?

  1. 1
  2. 2