X
Tap here to go to the mobile version of the site.

Support Forum

How can I download Firefox 4? I can only find no 5. I really need 4 so I can use the Google toolbar. My work depends on it.

Posted

Where can I download Firefox 4?

Where can I download Firefox 4?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.2 r153
  • iPhoto6
  • Office Live Update v1.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

David McRitchie 320 solutions 3092 answers

Firefox 4 has reached end of life, no support, no fixes, and should not be used.

You can get the Google Toolbar to work for you in Firefox 5, see the ed-meister's reply to a question

I've never found that I needed the Google Toolbar, I can invoke the Google translator with bookmarklet, or any other web translator. I can use Firefox to check my spelling and can even check the spelling on created web pages.


You can make Firefox Firefox 5.0 look like Firefox 3.6.19, see numbered items 1-10 in the following topic Fix Firefox 4.0 toolbar user interface, problems (Make Firefox 5.0, or 4.0.1, look like 3.6). Whether or not you make changes, you should be aware of what has changed and what you have to do to use changed or missing features.


Firefox 4.0 should not be used, but just so you won't mess up your profile by reinstalling an older version. And your reason does not justify using 4.0.1 because you can turn off compatibility as provided in the first link above..

For those that really need an earlier version of Firefox, find your system and the Firefox version you want in releases, download and start the install.

or with the latest of version 3
Note Mac OS X 10.4 user, and Mac OS X 10.5 users without Intel cannot upgrade to Firefox 4 or 5.

When reinstalling Firefox from a download, Firefox must be down once the installation starts. When the installation finishes, don't let the install start firefox for you. Instead end the install and start Firefox in your normal manner, thus preventing creating a new profile which does not have your bookmarks cookies, etc (but your old profile would still be around and would).


Google's response: [updated 07/19/2011 marked at bottom 0f their response ] provides alternatives.

Toolbar not available for Firefox 5 or newer versions : Install or uninstall - Toolbar Help http://www.google.com/support/toolbar/bin/answer.py?&&answer=1342452

But the ambiguity of if it ever would be updated, has now been made clear with a later statement from Google (see the-edmeister's reply) indicating that the Google Toolbar will never be updated for Firefox 5 and future Firefox versions.

Firefox 4 has reached end of life, no support, no fixes, and should not be used. You can get the Google Toolbar to work for you in Firefox 5, see the ed-meister's reply to a question *https://support.mozilla.com/en-US/questions/837473 I've never found that I needed the Google Toolbar, I can invoke the Google translator with bookmarklet, or any other web translator. I can use Firefox to check my spelling and can even check the spelling on created web pages. * https://support.mozilla.com/en-US/questions/841081 ---- You can make Firefox '''Firefox 5.0''' look like Firefox 3.6.19, see numbered items 1-10 in the following topic [http://dmcritchie.mvps.org/firefox/firefox-problems.htm#fx4interface Fix Firefox 4.0 toolbar user interface, problems (Make Firefox 5.0, or 4.0.1, look like 3.6)]. ''Whether or not you make changes, you should be aware of what has changed and what you have to do to use changed or missing features.'' ---- Firefox 4.0 should not be used, but just so you won't mess up your profile by reinstalling an older version. And your reason does not justify using 4.0.1 because you can turn off compatibility as provided in the first link above.. ''For those that really need an earlier version of Firefox, find your system and the Firefox version you want in releases, download and start the install.'' * ftp://ftp.mozilla.org/pub/firefox/releases/ :''or with the latest of version 3'' * http://www.mozilla.com/firefox/all-older.html : Note Mac OS X 10.4 user, and Mac OS X 10.5 users without Intel cannot upgrade to Firefox 4 or 5. When reinstalling Firefox from a download, Firefox must be down once the installation starts. When the installation finishes, don't let the install start firefox for you. Instead end the install and start Firefox in your normal manner, thus preventing creating a new profile which does not have your bookmarks cookies, etc (but your old profile would still be around and would). ---- Google's response: [updated 07/19/2011 marked at bottom 0f their response ] provides alternatives. Toolbar not available for Firefox 5 or newer versions : Install or uninstall - Toolbar Help http://www.google.com/support/toolbar/bin/answer.py?&&answer=1342452 But the ambiguity of if it ever would be updated, has now been made clear with a [http://googletoolbarhelp.blogspot.com/2011/07/update-on-google-toolbar-for-firefox.html later statement] from Google (see the-edmeister's reply) indicating that the Google Toolbar will '''never be updated for Firefox 5 and future Firefox versions'''.

Modified by David McRitchie

the-edmeister
  • Top 25 Contributor
  • Moderator
5387 solutions 39990 answers

The Google Toolbar "will not be supported on Firefox 5 and future versions."
http://googletoolbarhelp.blogspot.com/2011/07/update-on-google-toolbar-for-firefox.html

http://www.google.com/support/toolbar/bin/answer.py?answer=1342452&topic=15356%29


The Google Toolbar 7.1.20110512W version does work pretty good in Firefox 5.0 by using the Compatibility Reporter extension. But not every feature works 100%.
https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/

http://googlesystem.blogspot.com/2011/06/enable-google-toolbar-in-firefox-5.html

The Google Toolbar "will not be supported on Firefox 5 and future versions." <br /> http://googletoolbarhelp.blogspot.com/2011/07/update-on-google-toolbar-for-firefox.html http://www.google.com/support/toolbar/bin/answer.py?answer=1342452&topic=15356%29 The Google Toolbar '''7.1.20110512W''' version does work pretty good in Firefox 5.0 by using the Compatibility Reporter extension. But not every feature works 100%.<br /> https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/ http://googlesystem.blogspot.com/2011/06/enable-google-toolbar-in-firefox-5.html
David McRitchie 320 solutions 3092 answers

Thanks Ed for removing the ambiguity.

Thanks Ed for removing the ambiguity.
geejaye 0 solutions 1 answers

Helpful Reply

This page is an easier way to download Firefox 4.0: http://www.mozilla.com/en-US/products/download.html?product=firefox-4.0&os=win&lang=en-US , as this links starts the download process asap.

I needed to upgrade to Firefox 4.0+ for an add-on that I really needed. However, I can't use Firefox 5.0, as I randomly checked 3 add-on's I had: "Firefox PDF", "Delicious Bookmarks" and "After the Deadline", and none of them worked with Firefox 5.0. In fact, I will have to download alpha versions, etc., to get these add-ons to work with Firefox 4.0.

This page is an easier way to download Firefox 4.0: http://www.mozilla.com/en-US/products/download.html?product=firefox-4.0&os=win&lang=en-US , as this links starts the download process asap. I needed to upgrade to Firefox 4.0+ for an add-on that I really needed. However, I can't use Firefox 5.0, as I randomly checked 3 add-on's I had: "Firefox PDF", "Delicious Bookmarks" and "After the Deadline", and none of them worked with Firefox 5.0. In fact, I will have to download alpha versions, etc., to get these add-ons to work with Firefox 4.0.
David McRitchie 320 solutions 3092 answers

Please see the following MozillaZine article:

"Using Google Toolbar features without toolbars"
http://kb.mozillazine.org/Using_Google_Toolbar_features_without_toolbars
Please see the following MozillaZine article: :"Using Google Toolbar features without toolbars" :http://kb.mozillazine.org/Using_Google_Toolbar_features_without_toolbars
the-edmeister
  • Top 25 Contributor
  • Moderator
5387 solutions 39990 answers

@dmcritchie

Excellent article in the MozillaZine KB! I have never actually used the Google Toolbar either, but I have played with it a bit to see what it is all about to try to help users with at least the basics. Looks to me like you covered the alternatives quite good.

@dmcritchie Excellent article in the MozillaZine KB! I have never actually used the Google Toolbar either, but I have played with it a bit to see what it is all about to try to help users with at least the basics. Looks to me like you covered the alternatives quite good.
Kureo 0 solutions 1 answers

Thanks so much geejaye!

At first 5 was fine and I like some of the new features, but then I started finding more and more glitches and bugs and things I wanted to do that I couldn't.... It was just getting to be a real pain. So, I decided to go back to 4 until they worked the kinks out of 5. They've done and amazing job of erasing it from the net though, haven't they. I've been searching for ages for a link to download old reliable 4 and this is the first I've found.

So, I'll sit tight with my out of date firefox until they can get the bugs in 5 worked out. *g*

Cheers mate!

Thanks so much geejaye! At first 5 was fine and I like some of the new features, but then I started finding more and more glitches and bugs and things I wanted to do that I couldn't.... It was just getting to be a real pain. So, I decided to go back to 4 until they worked the kinks out of 5. They've done and amazing job of erasing it from the net though, haven't they. I've been searching for ages for a link to download old reliable 4 and this is the first I've found. So, I'll sit tight with my out of date firefox until they can get the bugs in 5 worked out. *g* Cheers mate!

Modified by Kureo