X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why google search engine has been replaced by imesh.com? How to restore google search engine in Firefox?

Posted

'Google Search Engine in Firefox has been replaced by i mesh.com without my consent and knowledge. I have tried all possible way to restore Google search engine in fire fox without any success. Hence I require help to restore Google search engine in Firefox earliest.

Additional System Details

This happened

Every time Firefox opened

This started when...

From 11th July 2011 midnight

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.5
  • Version 2.1.6.0
  • Java Plug-in 1.4.1_01 for Netscape Navigator (DLL Helper)
  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • 12.0.1.647
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Google Update
  • Shockwave Flash 10.2 r153
  • Picasa plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60531.0
  • Office Live Update v1.3
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

No information availalble on troubleshooting

jscher2000
  • Top 10 Contributor
2349 solutions 20824 answers

There may be multiple parts to this issue, based on past discussions.

(1) iMesh Media Bar add-on

This add-on may be hijacking your home page and location bar search. If you don't need this toolbar, you can uninstall it using the Windows Control Panel, Add/Remove Programs. Look for "Media Bar".

After uninstalling, restart Firefox and check here to make sure it's gone:

orange Firefox button or Tools menu > Add-ons > Extensions category

(2) Reset your home page

Visit the page you want to be your home page and then check out the methods described in this article: How to set the home page | How to | Firefox Help.

(3) Location bar search

If this was changed, you can change it back to Google using the tips in this thread: How do I get FF4 to use Google's I'm feeling lucky feature? | Firefox Support Forum | Firefox Help.

Does it work?