X
Tap here to go to the mobile version of the site.

Support Forum

I am having problems with 301 redirects being cached. How do I clear FF5's memory?

Posted

I built some websites and never really thought about which redirect should be used when blocking someone from accessing a page requiring a login, so they were all 301's, by default. This has not been a problem until now. FF5 seems to cache this information and I can not access those pages anymore, even after successfully logging in. Clearing FF's cache does not seem to clear this information.

I built some websites and never really thought about which redirect should be used when blocking someone from accessing a page requiring a login, so they were all 301's, by default. This has not been a problem until now. FF5 seems to cache this information and I can not access those pages anymore, even after successfully logging in. Clearing FF's cache does not seem to clear this information.

Additional System Details

Installed Plug-ins

  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • DivX VOD Helper Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60531.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

rewtroy 0 solutions 2 answers

Helpful Reply

I, too, had this problem.

Then I found that the Web Developer toolbar's "Disable" > "Disable Cache" option seemed to clear a bad 301 redirect for me.

Looking at about:config, it appears to be toggling browser.cache.disk.enable to false. Toggling that to false directly also does the trick. Toggle back to true to have it cache again (and I bet other things are cached).

Worked for me on FF 5.0.1 and Web Developer toolbar 1.1.9.

I, too, had this problem. Then I found that the Web Developer toolbar's "Disable" > "Disable Cache" option seemed to clear a bad 301 redirect for me. Looking at about:config, it appears to be toggling browser.cache.disk.enable to false. Toggling that to false directly also does the trick. Toggle back to true to have it cache again (and I bet other things are cached). Worked for me on FF 5.0.1 and Web Developer toolbar 1.1.9.
rewtroy 0 solutions 2 answers

Rats, this was only temporary. Re-enable the cache and the old cached setting returns.

Rats, this was only temporary. Re-enable the cache and the old cached setting returns.
ftobin 0 solutions 3 answers

Helpful Reply

If you simply clear your cache that should help solve the issue as long as you don't get more 301's.

If you simply clear your cache that should help solve the issue as long as you don't get more 301's.
brokemybrowser 0 solutions 4 answers

I'm not sure the best solution should be to empty the browsers cache, especially if you are trying to debug just one website.

Is there not a way to only delete redirect cache ? Or even better, an option to tell Firefox not to cache 301 redirects (yes, even if they are supposed to be permanent).

I'm not sure the best solution should be to empty the browsers cache, especially if you are trying to debug just one website. Is there not a way to only delete redirect cache ? Or even better, an option to tell Firefox not to cache 301 redirects (yes, even if they are supposed to be permanent).