X
Tap here to go to the mobile version of the site.

Support Forum

Need the latest version for Google+ but cannot get it?! Tried 4 times and still 3.5.4 - what am I doing wrong?

Posted

I am trying to switch to google+. Unsupported browser error. When I try to update to Firefox 5.o, go through all the steps, it keeps me at 3.5.4. What am I doing wrong? Do I need to uninstall and start from scratch? Confused.

I am trying to switch to google+. Unsupported browser error. When I try to update to Firefox 5.o, go through all the steps, it keeps me at 3.5.4. What am I doing wrong? Do I need to uninstall and start from scratch? Confused.

Additional System Details

This happened

Every time Firefox opened

This started when...

I was invited to join Google+ June 8th

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Citrix ICA Client Plugin (Win32)
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Shockwave Flash 10.3 r181
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60531.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729) FBSMTWB

More Information

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729) FBSMTWB
I need this user agent stream to show/be Firefox 5.0

the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40161 answers
https://support.mozilla.com/en-US/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser