X
Tap here to go to the mobile version of the site.

Support Forum

Firefox shows Errror Code "ssl_error_bad_mac_read" when trying to access Secure Sites

Posted

When I try to access secures sites (URLs with https) Firefox shows me the error code "ssl_error_bad_mac_read".

This problem only appears in Firefox not in Internet Explorer and it also appears when I use Firefox in Secure Mode. The problem appeared this morning for the first time, until yesterday everything worked fine and I didn't install or update any new PlugIns, Addons, Firewalls or something like that.

I tried to make the SSL-Test from Boston University you propose on your help page and couldn't access that page either. I use Firefox with the version 5.0 and would be glad to receive any hint to solve the problem.

When I try to access secures sites (URLs with https) Firefox shows me the error code "ssl_error_bad_mac_read". This problem '''only''' appears '''in Firefox not in Internet Explorer''' and it '''also''' appears when I use Firefox in '''Secure Mode'''. The problem appeared this morning for the first time, until yesterday everything worked fine and I didn't install or update any new PlugIns, Addons, Firewalls or something like that. I tried to make the SSL-Test from Boston University you propose on your help page and couldn't access that page either. I use Firefox with the version 5.0 and would be glad to receive any hint to solve the problem.

Modified by k_a_r_o_l_a

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • BitDefender QuickScan Web Netscape Plugin
  • Zylom Plugin
  • 6.0.12.1212
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • npdivxplayerplugin
  • getplusplusadobe16263
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Shockwave Flash 10.3 r181
  • DivX Web Player version 2.0.0.254
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Panda ActiveScan 2.0 Plugin for Firefox
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

Hasan 469 solutions 5600 answers

Helpful Reply

Open Firefox -> go to Tools Menu -> Options -> Advanced -> Encryption -> Protocols section -> Put Checkmarks on both options -> Certificates section-> select Radio Button Option 2 -> Click OK.

Open Firefox -> go to Tools Menu -> Options -> Advanced -> Encryption -> Protocols section -> Put Checkmarks on both options -> Certificates section-> select Radio Button Option 2 -> Click OK.

Helpful Reply

Thanks for your help, but exactly all of these options have already been checked.

Thanks for your help, but exactly all of these options have already been checked.
Hasan 469 solutions 5600 answers

- Open Firefox -> got to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. You can enable the Add-ons later. Check if its working.

- Open Firefox -> got to Help Menu -> select "Restart with Add-ons Disabled" Firefox will close then it will open up with just basic Firefox. You can enable the Add-ons later. Check if its working.

Question owner

Thanks for the hint, but since this afternoon the matter seemed to have resolved itself. Without having anything changed I could access secure sites with Firefox.

But given the fact that I have found several similar (unsolved) problem definitions in other forums where the people told that the problem appeared once again from time to time, I will keep your hint in mind and will check if it'll help in case it happens again.

Thanks for the hint, but since this afternoon the matter seemed to have resolved itself. Without having anything changed I could access secure sites with Firefox. But given the fact that I have found several similar (unsolved) problem definitions in other forums where the people told that the problem appeared once again from time to time, I will keep your hint in mind and will check if it'll help in case it happens again.