X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox wont keep my yahoo login details

Posted

I have to keep logging into my Yahoo Page. I didnt use to.

Even when I switched my cookies to Exceptions only and delete the rest. But now everytime i close Firefox and re-open it, my Yahoo setting is gone.

I've clicked on Page info and checked that its Permission Cookie is set to allow, but still when Firefox close, the cookie is gone.

All my other Exceptions are fine, except this its driving me bloody mad!!!!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Default Plug-in
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • McAfee MSC FF plugin DLL
  • McAfee Virtual Technician plugin for Mozilla (Gecko Version: 1.8b1)
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18 ( .NET4.0E)

More Information

ive put
uk.my.yahoo.com
my.yahoo.com
www.yahoo.co.uk
www.yahoo.com
in the exception list

Hasan 477 solutions 5600 answers

Login to Yahoo! Mail by typing User ID and Password, checkmark on "Keep me signed in" and Sign-In to Yahoo! Mail. When you are done with Yahoo! Mail don't SignOut, just close the browser window.

When you restart Firefox and go to Yahoo! Mail again, you will not need to Login again.. :D Yahoo! Mail will start with your User ID already logged in.

Check and tell if its working.

Question owner

thanks but ive already done that first

Hasan 477 solutions 5600 answers

Open Firefox -> go to Tools Menu -> Options -> Privacy section -> History section -> Firefox will: select "Use custom settings for history" -> Place Checkmarks on all Options EXCEPT Last Option -> REMOVE Checkmark from Last Option (Clear history when Firefox closes)

Press OK and check if its working.

Question owner

nope, that didnt work either.

thanks for the advise thou

Hasan 477 solutions 5600 answers

Open Firefox -> go to Tools Menu -> Options -> Privacy section -> History section -> Firefox will: select "Use custom settings for history" -> PLACE CHECKMARKS on:

    1) Remember my Browsing History
    2) Remember Download History
    3) Remember Search History
    4) Accept Cookies from sites -> select "Exceptions..." button -> Click "Remove All Sites" at the bottom of "Exception - Cookies" Window
      4a) Accept Third-party Cookies -> under "Keep Until" select "They Expire"

-> REMOVE CHECKMARK from Last Option (CLEAR HISTORY WHEN FIREFOX CLOSES)

Press OK and check if it works.

Modified by Hasan

Question owner

@mha007 thank you so much for all your suggestions, but sadly none of them work.

search to web and found that for Firefox its to do with the either cookie or permission.sqlite. So I close Firefox and set these two tmp and re-open Firefox and logged in again. and by golly its worked!!!

mikepalmer 0 solutions 1 answers

RickyJune, ' Can you please clarify what you did to fix this problem.

Thanks Mike

Question owner

FIRST, close Firefox then on your computer there is a file in

C:\Documents and Settings\"YOUR NAME"\Application Data\Mozilla\Firefox\Profiles\enmh4hod.default

there are two files cookies.sqlite and permissions.sqlite

rename these to permissions.sqlite.tmp forces FireFox to create new ones

OPEN FireFox. Go to Options-->Privacy-->and change setting Keep Until.....to "ask me everytime"

Then visit all your favourite websites and log on and press ALLOW when asked if you want to accept a cookie EVERYTIME. By choosing ALLOW they go straight onto your Exception list.

when ya done. close Firefox.

Now re-open Firefiox and you should find that all your websites you visit are still logged in.

You can change the Option back to Keep until.........I close FireFox

Let me know if it works

Modified by rickyjune

Rebeccamack 0 solutions 1 answers

I had the same problem. This is how I solved it: click on the Firefox menu box at the top left of the page. Click on options in the right column. Select the General tab (it will probably be the one showing). The first option is: When Firefox starts: Select the option that says: Show my windows and tabs from the last time. Then click on OK. Hope this works for you too.

Hasan 477 solutions 5600 answers

User name and password not remembered

http://kb.mozillazine.org/User_name_and_password_not_remembered

Check and tell if its working.