X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

when I install Firefox, it automatically includes the Babylon tool bar, how do I get rid of it?

Posted

The Babylon tool bar and web browser get automatically installed when I install firefox. It takes over Firefox. Will not let me change the starting page (always goes to babylon - THAT I DO NOT WANT). i THINK YOU GUYS HAVE A PROBLEM. WHEN I TRY TO UNINSTALL BABYLON, IT DOESN'T APPEAR ANYWHERE IN THE LIST OF PROGRAMS.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.112 Safari/534.30

More Information

cbeasley
  • Moderator
5 solutions 46 answers

Helpful Reply

Firefox does not include the Babylon toolbar in it's installation. I'm not sure how it got onto your computer, but here's an answer by Munkyrench from this thread. Other excellent responses start about halfway down the page.

https://support.mozilla.com/en-US/questions/746530#answer-102882

"YESSS!!! Ok people here's what you do!

1. Type about:config in the bar and hit enter, ignore the funny warning

2. Type Babylon in the search query and hit enter. This will show all Babylon Sh%t in your browser

3. Right click "extensions.BabylonToolbar.firstRun" and select "Toggle"

4. Select keyword.URL (This is the fixed line, yours will have Babylon in it) and "Modify" it and copy/paste this in:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q="

5. Exit the tab and restart your browser!

6. BINGO it SHOULD be fixed!

Hope this fixes your guys problems! It took me a while to figure out what this thing was doing then remembered about:config! "

Helper7677 165 solutions 1653 answers

The reply from cbeasley will reset the search engine used in the location bar, etc., but will not un-intall Babylon from your system. In fact, Babylon may change what cbeasley had you do, the next time you exit and re-start Firefox.

  1. Remove Babylon from your system by following these instructions:
  2. Then follow the instructions from cbeasley
  3. How to set your home page: How to set the home page
ninara 0 solutions 1 answers

Nope, sorry, this did not help. The stupid thing is still here..

Hasan 477 solutions 5600 answers

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. Now do this:

-> go to View Menu -> Toolbars -> select Menu Bar and Navigation ToolBar -> unselect All Unwanted toolbars

-> go Tools Menu -> Clear Recent History -> Time range to clear: select EVERYTHING -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache, Site Preferences -> click "Clear Now"

-> go to Tools Menu -> Options -> General -> When Firefox starts : select "Show My Home Page" -> Type the address of the website which you want to be your HomePage e.g. http://www.google.com -> place Checkmark on "Show the Downloads window when downloading a file" -> select Radio Button option2 "Always ask me where to save files"

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Tools Menu -> Options -> Privacy -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from "Permanent Private Browsing mode" -> place CHECKMARKS on:

1) Remember my Browsing History 2) Remember Download History 3) Remember Search History 4) Accept Cookies from sites -> select "Exceptions..." button -> Click "Remove All Sites" at the bottom of "Exception - Cookies" window

  4a) Accept Third-party Cookies -> under "Keep Until" select "They Expire"

-> REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES

-> When using the Location Bar, suggest: select "History and Bookmarks"

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites

-> Click OK on Options window

-> click the Favicon (small drop down menu icon) on Firefox SearchBar (its position is on the Right side of the Address Bar) -> click "Manage Search Engines" -> select all Unwanted Search Engines and click Remove -> click OK

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious Extensions (Add-ons) -> Restart Firefox

You can enable your Known & Trustworthy Add-ons later. Check and tell if its working.