X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

After upgrading to Firefox 5, youtube videos will not play. I just get a black screen with no audio or video. Is there any way to fix this?

Posted

The details are in the question itself Is anyone else having this problem? I think I might go back to chrome.

The details are in the question itself Is anyone else having this problem? I think I might go back to chrome.

Additional System Details

Sites Affected

http://youtube.com

Installed Plug-ins

  • np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Google Update
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • NPWLPG
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

artifex1 0 solutions 2 answers

I am having the same problem and just realized that the videos load with no problem if using "private browsing". Checked the Flash setting in normal and private browsing and the seem to be the same.

I am having the same problem and just realized that the videos load with no problem if using "private browsing". Checked the Flash setting in normal and private browsing and the seem to be the same.
djukak 0 solutions 2 answers

I too have same problem and it works in private browsing. I don't know why.

I too have same problem and it works in private browsing. I don't know why.
MeChAnIkAnGeL 0 solutions 1 answers

you're right! thanks that was really driving me nuts. at least this way i can see vids until firefox does something about it :) Thanks!

you're right! thanks that was really driving me nuts. at least this way i can see vids until firefox does something about it :) Thanks!

Question owner

This may not work for everyone, but I decided to clear my site preferences and youtube video playback went back to normal. Try it out, it might work for you too.

Hold Ctrl, Shift, Del Check the "site preferences" box Click "clear now"

This may not work for everyone, but I decided to clear my site preferences and youtube video playback went back to normal. Try it out, it might work for you too. Hold Ctrl, Shift, Del Check the "site preferences" box Click "clear now"
showup2work 0 solutions 1 answers

Helpful Reply

This worked for me...Hold Ctrl, Shift, Del CHECK BOXES, cookies, cache and site preferences and then "CLEAR NOW"

This worked for me...Hold Ctrl, Shift, Del CHECK BOXES, cookies, cache and site preferences and then "CLEAR NOW"
djukak 0 solutions 2 answers

This works........

This works........
mnewland 0 solutions 1 answers

thank you so much! this solved my problem, which was making me crazy!!!

thank you so much! this solved my problem, which was making me crazy!!!
Morello 0 solutions 1 answers

i make as all tell me and nothing change. i make Hold Ctrl, Shift, Del CHECK BOXES, cookies, cache and site preferences and then "CLEAR NOW" and i open private browsing too but nothing changes and i dont know why, any one help me please Thanks.

i make as all tell me and nothing change. i make Hold Ctrl, Shift, Del CHECK BOXES, cookies, cache and site preferences and then "CLEAR NOW" and i open private browsing too but nothing changes and i dont know why, any one help me please Thanks.
HolisticPlantHealth 0 solutions 1 answers

Helpful Reply

I found a solution for me here http://www.google.com/support/forum/p/youtube/thread?tid=188ccea635a83962&hl=en&fid=188ccea635a839620004a77b30dd01ba Apparently Youtube put its videos behind a httpS link and if the browser URL is just http it wont allow the player controls to load. Just got to httpS://www.youtube.com and all URLs will be with the httpS and will load properly

I found a solution for me here http://www.google.com/support/forum/p/youtube/thread?tid=188ccea635a83962&hl=en&fid=188ccea635a839620004a77b30dd01ba Apparently Youtube put its videos behind a httpS link and if the browser URL is just http it wont allow the player controls to load. Just got to httpS://www.youtube.com and all URLs will be with the httpS and will load properly
SqueakyPics 0 solutions 3 answers

The https seems to be the culprit. I've made a short cut to https://www.youtube.com and can see the videos from there. The above link on google support says something about adding Youtube to 'trusted sites' but I can not find a way of doing this in Firefox5

The https seems to be the culprit. I've made a short cut to https://www.youtube.com and can see the videos from there. The above link on google support says something about adding Youtube to 'trusted sites' but I can not find a way of doing this in Firefox5
skiwillgee 0 solutions 1 answers

Window7, 64bit machine

Internet Explorer would play the videos okay but Firefox stopped viewing the YouTube videos some time yesterday for me. First I did a system restore to a point about 72 hours before the problem started. Didn't work.

Next I uninstalled and re-installed latest Adobe Flash. Didn't work.

I noticed Java had notified me of new update the same day the problem appeared. I installed the new Java. Now things work. I'm puzzled at the coincidence of failure at the same time Java notified an update.

Oh well, these steps I described were taken and things are working now.

Window7, 64bit machine Internet Explorer would play the videos okay but Firefox stopped viewing the YouTube videos some time yesterday for me. First I did a system restore to a point about 72 hours before the problem started. Didn't work. Next I uninstalled and re-installed latest Adobe Flash. Didn't work. I noticed Java had notified me of new update the same day the problem appeared. I installed the new Java. Now things work. I'm puzzled at the coincidence of failure at the same time Java notified an update. Oh well, these steps I described were taken and things are working now.
artifex1 0 solutions 2 answers

Yes, the "https" works.

Yes, the "https" works.
Art Funkhouser 0 solutions 1 answers

Tweaktube was causing the problem on my PC (Vistta, Firefox 5). I disabled Tweaktube and YouTube works fine now.

Tweaktube was causing the problem on my PC (Vistta, Firefox 5). I disabled Tweaktube and YouTube works fine now.
cerpin_taxt 0 solutions 1 answers

in my case is the "adblock plugin" after revise filter list and disable "http://s.ytimg.com/yt/swfbin/watch_as3-vflwQAc_A.swf" youtube works perfectly other option is using a "proxy server" like "hyde my ass" and this works fine

in my case is the "adblock plugin" after revise filter list and disable "http://s.ytimg.com/yt/swfbin/watch_as3-vflwQAc_A.swf" youtube works perfectly other option is using a "proxy server" like "hyde my ass" and this works fine

Modified by cerpin_taxt

letmein2c 0 solutions 1 answers

You solved my problem!! Very much appreciated.

You solved my problem!! Very much appreciated.