X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

On the FAFSA web page, my updated Firefox browser is incompatible; I need this setup to operate the site: Mozilla Firefox 3.5.x and 3.6.x. Does this mean I need to downgrade? If so, how do I do that?

Posted

I talked to an customer service representative of the site and they repeated that I needed those specific browsers. Mine is apparently too advanced to run properly. How do I use the older browser?

Additional System Details

Sites Affected

http://fafsa.ed.gov

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.5
  • Version 2.1.6.0
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • 1.9.0009.1
  • npbyond
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Google Update
  • Pando Web Plugin
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • GEPlugin
  • 4.0.60531.0
  • Office Live Update v1.5
  • NPWLPG
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

Raine Dragon 8 solutions 99 answers

You can probably use the portable version and then not have to downgrade. :)

check out this topic for more info: https://support.mozilla.com/en-US/questions/843197