Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Yahoo is called from the address bar even with keyword.enable false

more options

When entering a single word, like cnn, instead of looking for www.cnn.com, http://br.search.yahoo.com/, is being called. fixup is set correctly The keyword values are set as below keyword.enabled;false keyword.URL; Operating system: windows 7 professional, english Firefox 5 is english version also.

All Replies (5)

more options

With keyword.enabled set to false, my guess is that your ISP is redirecting those searches to a search engine that pays them for directing searches there.

That started happening about three years ago here in North America, first with RoadRunner, then one by one the other ISP's started doing it too. The ISP's refer to it as as a "Domain Helper Service". Most ISP's have a way to Opt Out of that "feature". This is the page where I can Opt Out with my ISP.
http://dns-opt-out.comcast.net/help-index.php

Check with your ISP and ask if that is what they are doing, and where there Opt Out page is located at their web site.

more options

It is not an ISP problem: 1- It worked OK with Firefox 3.6;

2- I installed Firefox 5 on another computer, using the same network, with the same options, AFAIK, and it works OK.

I suppose an option set earlier may be causing the problem, but I could'nt find clues.

more options

Try a new Firefox Profile, to see if the problem is with your current Profile.
http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows


Don't delete or do anything with with your current Profile, just see what happens with a new Profile.

Modified by the-edmeister

more options

Thanks - it worked!!!

more options

You're welcome. Now see this - http://support.mozilla.com/en-US/kb/Recovering+important+data+from+an+old+profile

Please click the Solved It button next to the answer that solved your Firefox support issue, it appears when you are logged in, so this thread gets marked as Solved to help other users who may have this same problem.