X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

After downloading service pack 1 for Windows 7 Firefox did not respond anymore (I got the startscreen, but could not do anything, it "hang"), after a roll back Firefox did work again: are Firefox and SP1 incompatible?

Posted

After implementing SP1 for Windows 7 Firefox "hang"(I got the startscreen, but could not do anything: no response). After a roll back removing SP1 Firefox works again.

I installed SP1 also some months ago and had the same problems, also then this was solved also by a roll back removing SP1.

Does Firefox have problems in combination with SP1? How to solve this? Thanks.

Additional System Details

This happened

Every time Firefox opened

This started when...

after implementing Service pack 1 for Windows 7

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • GEPlugin
  • 4.0.60531.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Could not find this option in my (dutch) version of help for Windows 7.
Firefox 4.0.1
Windows 7

alan_r 58 solutions 753 answers

No problem for me. 7x64 Fx 3,4 or 5. I haven't heard of any problem.

Suggest you work through this(Safe Mode, Problematic Extensions etc) -

https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes

Question owner

Followed the given advice: installed SP1 again, ran Firefox in safemode, disabled other running programs as mutorrent, still Firefox didnt work. I had internetconnection (after restarting mutorrent this did work, the app telling me what the weather outside is worked) but no Firefox: as previous time I got the start screen, but could not browse the internet.

I also tried to start the Internet Explorer and it also looked as if that application had problems (but that can also be because I did not use it for a while - old version or whatever - and it is not my standard browser).

Have again performed a roll back in order to remove SP1, now Firefox works again.

If somebody has advice it would be very welcome!