X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

System requirements for the latest version of Firefox

Posted

I have an old notebook, and it's impossble at the moment to heal the O.S, which is seriously deteriorated by use, completely worn out, let's say. It used to be XP home, it's SP2, but several antivirus told me, when trying to install, it is not compatible, for it needs SP 2 or upper! I don't even dare to update Adobe Flash for the same reason. So, I need t know, before I lose my actual Firefox, which are the OS requirementes for the latest version of this product. Thank you.

Additional System Details

This happened

Not sure how often

This started when...

still not stated, trying to avoid it.

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 8.2.6
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Winamp Application Detector
  • Default Plug-in
  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Panda ActiveScan 2.0 Plugin for Firefox
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18

More Information

Current Firefox version: 3.6.18
OS Windows XP
Installed plugins:
* Adobe PDF Plug-In For Firefox and Netscape 8.2.6
* NPRuntime Script Plug-in Library for Java(TM) Deploy
* Winamp Application Detector
* Default Plug-in
* Shockwave Flash 10.2 r152
* Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
* Panda ActiveScan 2.0 Plugin for Firefox
* Npdsplay dll
* DRM Store Netscape Plugin
* DRM Netscape Network Object
I don't know what other info you need.

Gryllida 76 solutions 892 answers

Chosen Solution

Firefox 5 system requirements

Question owner

Thank you!