X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

what version of windows do you need for the upgrade?

Posted

I haven't been able to upgrade my windows from 2000 to XP or anything newer. I started using firefox because it didn't slow down my computer and exployer I never liked. If I upgrade the flashplayer you are recommending will it slow down my computer? I'd like to know before I upgrade.

Chosen solution

http://www.adobe.com/products/flashplayer/systemreqs/ seems to say that Windows 2000 is not supported by current versions of Adobe Flash player.

Older versions of Adobe Flash are insecure, and it is not recommended to keep using them on all websites.

https://addons.mozilla.org/en-US/firefox/addon/flashblock/ can allow you to play only the Flash instances you want by clicking on them.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Motive Plugin for Mozilla Browsers
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18

More Information

Gryllida 76 solutions 892 answers

Chosen Solution

http://www.adobe.com/products/flashplayer/systemreqs/ seems to say that Windows 2000 is not supported by current versions of Adobe Flash player.

Older versions of Adobe Flash are insecure, and it is not recommended to keep using them on all websites.

https://addons.mozilla.org/en-US/firefox/addon/flashblock/ can allow you to play only the Flash instances you want by clicking on them.