X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Proxy resets to HTTP Proxy 127.0.0.1 Port 52848 This is not good

Posted

Whenever I close my Firefox session, my proxy reverts to HTTP Proxy 127.0.0.1 Port 52848. I have to go in and manually switch to automatic Proxy detection in order to reopen Firefox again. Is this a virus, threat, malware, or some other bad intention? For some reason Firefox is not remembering my automatic proxy detection setting.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape
  • getplusadobe15235
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.2 r153
  • Next Generation Java Plug-in 1.6.0_16 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

eriamgh 0 solutions 1 answers

I finally resolved this problem by disabling the Personas add-on and then modifying my prefs.js file. Here's how:

Disable Personas in the Add-ons Menu - Tools>Add-ons (You still get to keep your current theme, so it wasn't a big deal for me)

Close Firefox.

Modify prefs.js - Go to C:\Users\"User Name"\AppData\Roaming\Mozilla\Firefox\Profiles and then open your profile folder (Mine is "gyte7fls.default") Right-click on the prefs.js file and choose Edit. This will open it in Notepad Look for the lines that read: "user_pref("network.proxy.http", "127.0.0.1"); user_pref("network.proxy.http_port", 52848);" Delete those. Then go to the line: "user_pref("network.proxy.type", 1);" and change the 1 to a 0. Save the document then open Firefox. That should work. It did for me.

jnetter 0 solutions 1 answers

Helpful Reply

I have exactly the same problem, but am not using personas. When I make the edits to prefs.js and restart, the setting reverts to manual proxy. Started when I upgraded to 5.

Walf 0 solutions 3 answers

Helpful Reply

Came across the same issue on a Windows PC, different port number but still 127.0.0.1 (the IP address that always translates as the computer you're on). The cause was a trojan which antivirus picked up and cleaned, if yours hasn't, get that sorted first. It seems to pick a random addon and inserts a bit of code that will change your proxy settings directly every time Firefox runs. This code remains even after the trojan itself is gone.

To solve it:

  1. Open Firefox, then go to Tools > Options > Advanced > Network tab > Connection section > Settings button. The Manual proxy section will be filled out, don't change anything yet. Note the number in Port.
  2. Without closing Firefox, go to Windows' Control Panel and open Internet properties and go to the Connections tab.
  3. If there are any connections listed in the Dial-up/VPN section at the top click on the first one to select it, then click the Settings button.
  4. In the menu that opens, look to see if the proxy is 127.0.0.1 and the port is that same as the one you just noted. If so, un-check the Use proxy server checkbox. and click OK.
  5. Repeat for any other Dial-up/VPN connections.
  6. Still in the Connections tab of Internet Properties, Click on the LAN Settings button and remove the the trojan's proxy settings as per step 4.
  7. Click OK buttons until you're back to Control Panel then close that window.
  8. Go back to Firefox and select Use system proxy settings then click OK and close the Options dialogue.
  9. Go to Tools > Addons > Extensions and disable all but the first one.
  10. Close Firefox then wait a few seconds then open it again. Go to the network settings as in step 1. If it's still set to Use system ... then that's not the corrupt addon, enable the next addon in the list an repeat this step. If it's automatically changed back to Manual You've found the corrupt addon!
  11. Go to the addon page again, remove the last enabled addon (not just disable), close and reopen Firefox as before.
  12. Install that addon again if you want, Firefox downloads a fresh copy so it should be all good.
  13. Enable the rest of your addons.

If that didn't solve it. More than one addon may have been affected so start again at step 9. If you're still having problems, you may still be infected. Get a geek to fix it.

DazzaCan 0 solutions 1 answers

Hi Ho thanks for the advice it was the Last Addon Persona's and I noticed that it had Auto updated itself on the 24-08-2011 the Proxy stuff started on the 25th so I have removed Persona's and I will leave it off thank you again Walf, Dazzacan

jmostert 0 solutions 1 answers

Thanks for the detailed instructions. The add-on that caused my issue was FiddlerHook 2.3.7.7.