Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't find a browser that seems to work with my MAC Os 10.3.9?

more options

Can't find a browser that works with my MAC Os 10.3.9 Panther.

I installed FF 2.0.12 and it would install but it says the browser will not work and I need to upgrade FF. I tried to upgrade to 3.6.17 but this system will not allow me to do this either and I am told that two things are screwing this up. First the compression of your file is not readable by macs unless I have 10.4 and because I have 10.3 as a Os I get the corrupted file message. I am also told that 3.6.17 won't work unless I upgrade my Os to 10.5 or later.

At this time I can't upgrade my Os.....so what version of firefox will install and actually operate on my current OS 10.3.9 Panther?

All Replies (2)

more options

Firefox 3.6 works with OSX 10.4.

The last version of Firefox that ran on 10.3 (according to system requirements) was Firefox 2. Because it has not been updated for years, Firefox 2 is not secure and definitely not recommended for use on the wild wild web.

I think you might be out of luck!

more options

Firefox 2.0.0.20 is the last ever release for Mac OSX 10.3.9 and earlier versions.
Get it here:
https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/mac/en-US/