X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Disable Plugin Check

Posted

Every time I open firefox, a "plugin check" website opens up. I thought that once I installed and updated all the pertinent updates for the plugins, the website would disappear when I re-opened firefox. However, the page wont' seem to disappear. I've done everything I could think of to get rid of this page. After updating all the plugins I restarted my pc, checked to make sure that my home page has not been changed the firefox plugin change, disabled all my plugins and even tried blocking the website via HOSTS.

(I am on firefox 3.6.17. I cannot update to 4.0 because some of the websites I use cannot support 4.0).

Help would be greatly appreciated. Thanks!

Website: https://www.mozilla.com/en-US/plugincheck/

Additional System Details

This happened

Every time Firefox opened

This started when...

2 Days ago.

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • MetaStream 3 Plugin r4
  • 1.7.0069.3
  • NPTURNMED
  • BitTorrent Plugin 1
  • npdivxplayerplugin
  • 2.0.0048.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Delivery Network Acceleration by BitTorrent™
  • DivX Web Player version 2.1.1.94
  • DivX VOD Helper Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.51204.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET4.0C)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96752 answers

See these articles for some suggestions:

mikeclark 3 solutions 35 answers

Chosen Solution

Vote for https://support.mozilla.com/oc/questions/832793

Question owner

Hey guys, thanks to 'kpatz' I found a solution!

In the address bar, type "about:config"

Click the "I'll be careful, I promise!" button if it appears.

Type "plugin" into the filter box.

Find the entry plugin.scan.plid.all and double-click on it to set it to false.

You're done!

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

@atish91

Disabling plugin.scan.plid.all is going to disable a number of Plugins, such as Flash, Real Player, and the OpenOffice plugin (which probably aren't causing this problem) in addition to the "offender". A smarter approach would be to disable your plugins in batches and work down to which one is causing this problem, or to disable them one at a time to find which one plugin is causing this problem. Then tell us which plugin was causing this problem for you, so that we can tell other users who also have this problem.

BTW "voting" in a support thread doesn't do any good to help us get a handle on which plugin is actually causing this problem.

SaintCO2 0 solutions 1 answers

I found that when I disable all of my Java Consoles (6.0.20 to 6.0.25), this issue goes away.

Does anybody know of any long term solution?

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

Type about:config in the URL bar and hit Enter.
If you see the warning, you can confirm that you want to access that page.

Pref = plugins.update.notifyUser if it shows as True, double-click that pref to toggle it to False

If that pref was already set to False, try disabling the QuickTime Plugin and then restart Firefox, to see if that is the culprit.

Modified by the-edmeister

kjpjr 0 solutions 4 answers

Does not work for me, neither does the quicktime plug in removal work. May have to go to chrome over this issue,

mikeclark 3 solutions 35 answers

I uninstalled Viewpoint Media Player (and the AOL IM client "AIM", since apparently that's what forced Viewpoint Media Player on to my system.)

Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled.

For me, after uninstalling Viewpoint Media Player, the "plugincheck always opening" problem then went away.

Modified by mikeclark

ser-borovsky 0 solutions 3 answers

Helpful Reply

Nothing helps to resolve this issue. Seems like Mozilla is forcing us to switch to some other browsers.

I personally added plug-in called "Block site" and added plug-in check page to the black list.

ser-borovsky 0 solutions 3 answers

Oh, forgot to mention Firefox 4 is something I'll never use. It has "microsoftish" approach to design and "user-friendlyness". Looks like I'm doomed to Chrome after so many years with Mozilla.

ser-borovsky 0 solutions 3 answers

plugins.update.notifyUser works only when you have all plugins disabled. Nice!

MasterThief 0 solutions 1 answers

@mikeclark:

This worked for me. Although I do with the Plugin Check people would be more responsive.

Im_bonafide 0 solutions 2 answers

Helpful Reply

Also posted at: https://support.mozilla.com/ta-LK/questions/832793#answer-197683

I did follow the steps, Open URL about:config, write: plugins.update, then I set: plugins.update.notifyUser = false. Except it was already User = false. So, I set it to User = true. When I reopened the browser it magically changed back to User = false. However, I continued to get that annoyance.

I went back into about:config > plugins.update > only this time on the line below plugins.update.notify, I (R) clicked plugins.update.url > modify > & deleted the url: https://www.mozilla.com/%LOCALE%/plugincheck/ and replaced with my normal home page url.

No more annoyance.

Modified by Im_bonafide

Teddington 0 solutions 4 answers

Yes you can change the target address for 'plugins.update.url'

Change it from 'https://www.mozilla.com/%LOCALE%/plugincheck' to your homepage, or leave it blank etc..

This will not stop you getting a random unwanted tab opening - but at least you won't have to look at the page about updates anymore.

I have set it to Google search, while waiting for a proper solution, hopefully.

Modified by Teddington

David Spalding 0 solutions 14 answers

[UPDATE] I was mistaken, turning off Plugins.Update.NotifyUser has not prevented the additional tab opening on https://www.mozilla.com/%LOCALE%/plugincheck/.

Please post what plug-ins are shown as needing a update on the Firefox check plug-ins page, that would help us determine why the page comes up.

Modified by David Spalding

demented.darling 0 solutions 1 answers

I disabled the Viewpoint Media Player plug-in (I couldn't find a way to uninstall it) and I'm still getting that stupid Plugin Check page popping up every time I start Firefox. I still haven't upgraded to 4.0 as it still doesn't support Norton Toolbar.

Chrome is looking better every day...

Modified by demented.darling

mikeclark 3 solutions 35 answers

Disabling the plugin is not enough. It must be uninstalled. Do this through Windows' Add/Remove Programs control panel.

tps5352 0 solutions 7 answers

ser-borovsky, good suggestion and I added that add-on also (for future use, perhaps). But the "cure" is only marginally better than the "disease." You still have a (now empty) extra tab page trying to start plus a message from Firefox saying that it was blocked that has to be deleted (or ignored). Don't get me wrong, it is better, but still annoying.

The best (least annoying) solution for me is still to put a different address (say for my homepage) in the "plugins.update.url" line in "about"config" so I just get two homepage tabs when I start FF (see suggestions for this above).

What _consistent_ evidence for the cause of this do we have?

- Not the version of Firefox (apparently happens in both 4 and 3.6.17).

- Not related to any specific configuration command in "about:config."

- Not related to any particular plugin (e.g., Viewpoint Media Player, Quicktime, Java, Flash Player), at least consistently for _all_ of us users.

What is the deal, Mozilla? How about a simple opt-out button on the Plugin Check page? Why not make the plugin check optional? Individual users have many good reasons NOT to automatically update software (e.g., compatibility issues, cost [to be forced to have to upgrade equipment], personal preferences, and because updates are not necessarily good and thoroughly tested to be bug-free by manufacturers).

Modified by tps5352

Cherie 0 solutions 1 answers

UPDATE to info below. Yes, what I posted works UNLESS I want to be able to use Flash in Firefox. Changing the setting for plugin.scan.plid.all completely disables the Flash plugin. I have changed the value of plugins.update.url to about:blank and will put up with two blank tabs opening whenever I open Firefox. Hope they come up with a fix for this soon, I'd really hate to change browsers  :(

_____

Posted earlier:

This worked for me:

I opened "about:config" and changed the setting for plugin.scan.plid.all from true to false.

No more Plugin Check page, no blank tab when opening. I just kept experimenting with toggling the settings on anything related to "plugin" until I found one that worked. Let me know if this helps anyone else!

Modified by Cherie

BaldFox 0 solutions 1 answers

THIS WORKED!!!!!

about:config > [filter] plugins.update > plugins.update.url > modify > delete the url: https://www.mozilla.com/%LOCALE%/plugincheck/ Click OK

No need to replace the URL. Just leave it blank and click OK.