Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The new Firefox 4 closes all my tabs without giving me the option to keep them as Firefox 3 did. Why can't we keep this feature?

  • 12 replies
  • 12 have this problem
  • 9 views
  • Last reply by PapaFrita

more options

I've installed Firefox 4 on my laptop but not on my PC because of 2 problems:- 1) Firefox 3 would always ask me if I wanted to retain the open tabs which I almost always do. Firefox 4 no longer offers this option and closes all tabs. Why?

2) Firefox 4 closes all float ins without either asking or notifying me. This not only makes my life more complicated it also prevents my customers downloading freebe offers because they are totally unaware of them. Why are you playing "Big Brother" and deciding for us what we can see online?

Blessed be

Karma Singh

Chosen solution

I think he is assuming you use the new FF4 Menu button. If you use the old 3.6 style, the options page would be under the 'Tools' menu.

Read this answer in context 👍 0

All Replies (12)

more options

Firefox now always stores the old session which you can access by going to the History menu and selecting "Restore Previous Session".

If you always open the last set of tabs, an alternative approach is this:

  1. Click the orange Firefox button, then select options to open the options window
  2. Go to the General panel
  3. Change the setting "When Firefox starts" to "Show my windows and tabs from last time"

I'm not sure what you mean by float ins.

more options

There IS no "options" in the mini-window which opens when one clicks on the Firefox button!!!!

This is an example of a float in which neither Firefox 3 nor 4 blocks: http://www.list.543bookshop.com Float in comes after 7 seconds This is an example of a float in which Firefox 3 does not block but Firefox 4 does: http://www.stopelectrosmog.com comes after 4 seconds

Blessed be

Karma

more options

Press F10 or tap the Alt key to bring up the "Menu Bar" temporarily.


Those pop-ups are created via JavaScript and timers. You would have to block that JavaScript to prevent such pop-ups from appearing.

more options

Neither of these suggestions does anything at all!

more options

Make sure that you do not run Firefox in full screen mode (press F11 to toggle).
If you are in full screen mode then hover the mouse to the top to make the Navigation Toolbar and Tab bar appear.
You can click the Maximize button at the top right to leave full screen mode or right click empty space on a toolbar and use "Exit Full Screen Mode" or press F11.


See also:

more options

I am not in full screen mode and you suggestion still does nothing.

more options

Also, from above:-

"Those pop-ups are created via JavaScript and timers. You would have to block that JavaScript to prevent such pop-ups from appearing. "

Of what use is this??????? I am asking WHY Firefox plays "Big Brother" with version 4 and pre-decides whether we are permitted to see pop-ups!

more options

I see the pop-up on http://www.stopelectrosmog.com/ in Firefox 4 as well as in Firefox 3.6, so if you do not see it in Firefox 4 then you have an extension that blocks it.

more options

Chosen Solution

I think he is assuming you use the new FF4 Menu button. If you use the old 3.6 style, the options page would be under the 'Tools' menu.

more options

This is my point: Just why has Firefox suddenly taken it upon itself to change the settings with neither my knowledge nor my consent when I upgrade from 3 to 4????

more options

OK. That works. But why does TonyE think that you access it by clicking on the orange Firefox symbol??????????????? V e r y strange.

more options

If you hide the Menu bar, the menu items (File, Edit, History, etc) instead can be accessed through a big orange Firefox button at the very top of the window. It can be useful if you want a slightly larger viewing area for webpages, but it can be easily toggled on and off.