Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get rid of Bing as my home page? It "took over" without my setting it as my home page.


I have a YTD toolbar that's appeared when I open Firefox, and I have had Google as my home page. Now YTD (aka Bing, aka Microsoft product) has taken over my home page, and I cannot reset it to Google or anything else. Any ideas?

Additional System Details

Sites Affected


Installed Plug-ins

  • npmnqmp 989898989877
  • Google Talk Plugin Video Accelerator version:
  • Version
  • Abacast Netscape Plugin
  • npmnqmp 07030901
  • Office Plugin for Netscape Navigator
  • ScorchNetscapePlugin
  • DivX Web Player version
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • Google Update
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • DivX® Content Upload Plugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.60310.0
  • Nexon Game Controller
  • Google Updater pluginhttp://pack.google.com/
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object


  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100914 Firefox/3.6.10

More Information

Xircal 334 solutions 3835 answers

First and foremost, update Firefox to 3.6.17 by clicking Help | Check For Updates.

There was a security breach at Comodo which is an SSL certificate provider recently whereby a number of fraudulent certificates were inadvertently issued. These allow a hacker to impersonate any site including online banking and the Firefox version you're running at the moment will not warn you that the site is a fake. The fraudulent certificates were blacklisted in v3.6.17 and beyond.

See: http://blogs.comodo.com/category/it-security/data-security/

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.

To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Go to Tools | Options | General

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

Last but not least, please visit the Plugins Check page and update where necessary.

To update Java, open Windows Control Panel and find Java in the list. Then click the update button. Do remember to uncheck the option to install the Yahoo Toolbar otherwise you'll get that piece of junk on your system too. See screenshot.