X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 4 now takes 60 seconds to start, it was 6 ! OS Windows Vista Home Premium. Why ?

Posted

Firefox 4 operated well when installed, but for no obvious reason it now takes 60 seconds to start,( it was 6) ! OS Windows Vista Home Premium.

Firefox 4 operated well when installed, but for no obvious reason it now takes 60 seconds to start,( it was 6) ! OS Windows Vista Home Premium.

Additional System Details

This happened

Every time Firefox opened

This started when...

10 days ago

Installed Plug-ins

  • Shockwave Flash 10.3 r181
  • Garmin Communicator Plug-In 2.8.1.0
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60310.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 6.0.12.857
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Version 0.9.9, copyright 1996-2009 The VideoLAN Teamhttp://www.videolan.org/
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

Try running Firefox in Troubleshoot Firefox issues using Safe Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.

Try running Firefox in [[Safe Mode]]. If it functions properly in that configuration, then one of your add-ons is the culprit.

Question owner

Thanks for the advice. Safe Mode started instantly and showed that it had disabled the two items under Extensions and Appearances . I have uninstalled these two { dotNET framework and Default} and disabled all plugins; I have also done all the resets on the SafeMode start dialogue. However, normal mode start is still 60 seconds !!

Thanks for the advice. Safe Mode started instantly and showed that it had disabled the two items under Extensions and Appearances . I have uninstalled these two { dotNET framework and Default} and disabled all plugins; I have also done all the resets on the SafeMode start dialogue. However, normal mode start is still 60 seconds !!
Xircal 334 solutions 3835 answers

Try creating a new Profile. This article explains the procedure: Profiles - Where Firefox stores your bookmarks, passwords and other user data.

If that works, you can retrieve data such as passwords, bookmarks etc., from the old (current) one and move them to the new one. See Profile Manager - Create, remove, or switch Firefox profiles

Try creating a new Profile. This article explains the procedure: [[Profiles]]. If that works, you can retrieve data such as passwords, bookmarks etc., from the old (current) one and move them to the new one. See [[Managing profiles]]

Question owner

I tried creating a new profile, but must have got something adrift; at one point even safe mode took 60 secs to start :-((( . I have now uninstalled FF4 and re-installed, but the problem remains .

I tried creating a new profile, but must have got something adrift; at one point even safe mode took 60 secs to start :-((( . I have now uninstalled FF4 and re-installed, but the problem remains .
Xircal 334 solutions 3835 answers

Could you please download the free version of Malwarebytes from http://www.malwarebytes.org/products/malwarebytes_free and run a full system scan to eliminate malware as the culprit as is often the case.

Could you please download the free version of Malwarebytes from http://www.malwarebytes.org/products/malwarebytes_free and run a full system scan to eliminate malware as the culprit as is often the case.

Question owner

Malwarebytes, Spybot, Microsoft security essentials all in regular use.

Malwarebytes, Spybot, Microsoft security essentials all in regular use.
Xircal 334 solutions 3835 answers

What do you have set as your home page?

What do you have set as your home page?

Question owner

http://secure.metoffice.gov.uk/aviation/reports.do?type=TAF&list=01
Xircal 334 solutions 3835 answers

I think it's likely because that site requires a user log in. So it will perform a credentials check before allowing you to proceed.

See the warning notice @ http://secure.metoffice.gov.uk/logon.jsp

You can test it by doing the following:

  1. In the location bar, type about:blank and hit Enter to display a blank page.

  2. Click the Firefox button, go to Options | Options | General.

  3. Go to Tools | Options | General

  4. Make sure it says "Show My Homepage" in the first dropdown menu.

  5. Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

  6. Close Firefox and then restart it again.

If it still takes 60 seconds to load, then post again, but I doubt it.

I think it's likely because that site requires a user log in. So it will perform a credentials check before allowing you to proceed. See the warning notice @ http://secure.metoffice.gov.uk/logon.jsp You can test it by doing the following:<br><br> #In the location bar, type '''about:blank''' and hit Enter to display a blank page.<br><br> #Click the Firefox button, go to '''Options '''| '''Options '''| '''General'''.<br><br> #Go to '''Tools '''| '''Options '''| '''General''' <br><br> #Make sure it says "''Show My Homepage''" in the first dropdown menu.<br><br> #Click the button called "'''Use Current Pages'''" to set the homepage to the one you have on the screen.<br><br> #Close Firefox and then restart it again. If it still takes 60 seconds to load, then post again, but I doubt it.

Question owner

Opening to blank still takes 60 seconds .

Opening to blank still takes 60 seconds .
Xircal 334 solutions 3835 answers

Please perform a cold boot i.e. close all programs and then shutdown the PC (or laptop). Wait a full two minutes before you boot up again. This will flush the system memory.

Please perform a cold boot i.e. close all programs and then shutdown the PC (or laptop). Wait a full two minutes before you boot up again. This will flush the system memory.

Question owner

Done. No change.

Done. No change.

Modified by Exatco

Question owner

Thanks for your input so far; I'm going to be offline now for most of the weekend. Rgds

Thanks for your input so far; I'm going to be offline now for most of the weekend. Rgds
Xircal 334 solutions 3835 answers

Please go to http://www.videolan.org/ and download the latest VLC player. The one you have installed at the moment dates from 1996 and poses a security risk. See VLC Media Player 1.1.9 closes security holes

Having said that, v1.1.9 is also vulnerable to certain exploits such as described here: VLC Media Player vulnerable to buffer overflow exploits. However, you'll be better off with this version than the one you have now. Just have to keep an eye on their site for future updates. Either that, or install this free Secunia tool which runs weekly scans for outdated apps: http://secunia.com/vulnerability_scanning/personal/

Do you have a rootkit detector installed which you can perform scans with? Rootkits are a type of malware which uses stealth tactics to hide from AV scanners. If you haven't got one, please download this one from Sophos and then run a scan: http://www.sophos.com/en-us/products/free-tools/sophos-anti-rootkit.aspx

Could you also please go to the Plugins Check page and update where necessary. There may be others you have installed which is causing the slowdown.

Please go to http://www.videolan.org/ and download the latest VLC player. The one you have installed at the moment dates from 1996 and poses a security risk. See [http://www.h-online.com/open/news/item/VLC-Media-Player-1-1-9-closes-security-holes-1226673.html VLC Media Player 1.1.9 closes security holes] Having said that, v1.1.9 is also vulnerable to certain exploits such as described here: [http://www.h-online.com/open/news/item/VLC-Media-Player-vulnerable-to-buffer-overflow-exploits-1237404.html VLC Media Player vulnerable to buffer overflow exploits]. However, you'll be better off with this version than the one you have now. Just have to keep an eye on their site for future updates. Either that, or install this free Secunia tool which runs weekly scans for outdated apps: http://secunia.com/vulnerability_scanning/personal/ Do you have a rootkit detector installed which you can perform scans with? Rootkits are a type of malware which uses stealth tactics to hide from AV scanners. If you haven't got one, please download this one from Sophos and then run a scan: http://www.sophos.com/en-us/products/free-tools/sophos-anti-rootkit.aspx Could you also please go to the [http://www.mozilla.com/en-US/plugincheck/ Plugins Check] page and update where necessary. There may be others you have installed which is causing the slowdown.

Question owner

Thanks, I have uninstalled VLC player; sophos reports no problems; and no updates were available for plugins. Start still takes 60 seconds.

Thanks, I have uninstalled VLC player; sophos reports no problems; and no updates were available for plugins. Start still takes 60 seconds.
Xircal 334 solutions 3835 answers

Adobe released a new version of Flash today namely 10.3.181.22

Videolan also released VLC player 1.1.10.

However, it doesn't sound like either of these will effect the current issue.

You mentioned that running Firefox in Safe Mode resolves the problem, so presumably one of your add-ons is the culprit.

Did you install any 'free' programs that might have introduced bundled software into your system? There's a list here which might help you identify some of them (if you did install something that is): Unwanted bundled apps

Also, do you have any of the add-ons listed here installed: http://kb.mozillazine.org/Problematic_extensions ?

Do you use Skype? If so, do you have the latest version? See 7th one from the top here: https://www.mozilla.com/en-US/blocklist/

Adobe released a new version of Flash today namely 10.3.181.22 Videolan also released VLC player 1.1.10. However, it doesn't sound like either of these will effect the current issue. You mentioned that running Firefox in Safe Mode resolves the problem, so presumably one of your add-ons is the culprit. Did you install any 'free' programs that might have introduced bundled software into your system? There's a list here which might help you identify some of them (if you did install something that is): [http://malwarebulletin.com/2011/02/11/calendar-of-updates/installers-hall-of-shame-unwanted-add-on-via-calendar-of-updates/ Unwanted bundled apps] Also, do you have any of the add-ons listed here installed: http://kb.mozillazine.org/Problematic_extensions ? Do you use Skype? If so, do you have the latest version? See 7th one from the top here: https://www.mozilla.com/en-US/blocklist/

Question owner

Still plodding on ! Nothing found, and the pre-installed Skype was uninstalled without being used . Startup still the same even with everything in the addons disabled ??

Still plodding on ! Nothing found, and the pre-installed Skype was uninstalled without being used . Startup still the same even with everything in the addons disabled ??
Xircal 334 solutions 3835 answers

I would be inclined to suggest using the option in start in Safe Mode and then checkmark "Reset all user preferences to Firefox defaults".

You'll lose your customizations, but it might save you a lot of time troubleshooting.

I would be inclined to suggest using the option in start in Safe Mode and then checkmark "Reset all user preferences to Firefox defaults". You'll lose your customizations, but it might save you a lot of time troubleshooting.

Question owner

I did this about four steps back

I did this about four steps back
Xircal 334 solutions 3835 answers

Did you have any success creating a new Profile? You seem to indicate earlier that something went pear-shaped somewhere.

Could you try again?

Also, I'll be on vacation from tomorrow for a month, so I won't be able to respond again until mid-July. But I'm sure one of the other guys will be able to take over shortly.

Did you have any success creating a new Profile? You seem to indicate earlier that something went pear-shaped somewhere. Could you try again? Also, I'll be on vacation from tomorrow for a month, so I won't be able to respond again until mid-July. But I'm sure one of the other guys will be able to take over shortly.