Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 wont install on Mac 10.5 when I tried to move download to app folder I received this error message

  • 2 replies
  • 28 have this problem
  • 6 views
  • Last reply by PeterSt

more options

The following disk images failed to mount Image:Firefox 4.0.1.dmg Reason: not recognized

All Replies (2)

more options

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

more options

You all suck - you create updates that satisfy your own hightech egos Now it's not just my version of Mac OSX [10.5] but I have to have a newer [Intel] processor as well - this along with Google's no longer supporting Firefox 3 proves that neither open source, integrity or even honesty exists in the higher echelons of the IT world It's only egos and money - you are victimizers, miscreants and bums a la dying egomaniac Jobs However, true open source. decency and (mostly women) of good will - soon will blow you all away enough said - in case you missed it - YOU DIDN'T HELP