Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After updating Firefox, deleted tabs from over a year ago are reappearing on startup.

  • 12 replies
  • 2 have this problem
  • 81 views
  • Last reply by cor-el

more options

I recently updated to the Firefox version suggested by Comcast. I had previously been running Firefox 6.-.- The "update" took me back to Firefox 4.0.1. (I did this because a Comcast tech was blaming a Comcast problem on Firefox. Finally I found a tech who identified the TRUE cause of that problem which had absolutely nothing to do with Firefox.)

After the "update" to version 4, old tabs that I had deleted a couple of years ago began reappearing on startup. I have deleted the bookmarks for these tabs, and cleared History and Downloads, Cookies, and Cache. But the outdated tabs continue to reappear when Firefox opens.

Chosen solution

You can try to trash or remove the entire Firefox folder to force Firefox to create a new default profile.

  • /Users/<user>/Library/Application Support/Firefox
Read this answer in context 👍 0

All Replies (12)

more options

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

If you see files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js then delete those as well.

Deleting sessionstore.js will cause App Tabs and Tab Groups to get lost, so you will have to create them again (make a note).

See:

more options

Thank you for your response, cor-el. I appreciate your time, and I learned things from your information. But... I deleted the two files as you suggested with no success, and the sessionstore.js returned unscathed in the folder on restart. Next I opened the js file, deleted its contents, and saved it. Still no success. (Curiously there were a couple of Netscape files in the profile folder -- does that sound right?) jmichea

more options

You did look in the correct location?
You did close Firefox first before removing the files?

What is the file date of the sessionstore.js file?


Help > Troubleshooting Information > Profile Directory: Open Containing Folder

more options

You were using Netscape 6.0, an older Mozilla derivative. I'd suggest that you export your bookmarks, close Firefox, make a backup copy of the "Mozilla" folder then delete it entirely. Upon next starting Firefox, you'll find that it starts with a clean slate (it will not be aware of any prior user data, including the errant tabs you mention). At that point, you can re-import your bookmarks and you should be all set.

You can find the Mozilla folder in question beneath the Library folder:

Home > Library > Mozilla

The 'home' folder is the one that is identified by your name or username in the Finder. Again, be sure to make a backup copy of the current Mozilla folder so that you can restore it, in the unlikely event that you need to.

more options

Somewhere in the links you referenced, I found an add-on for "Tools" menu to "Open profile folder..." which I installed and used to get to the profile folder. Yes, I had shut down Firefox.

more options

Did you previously use Aurora (Firefox 6) that you down graded to Firefox 4? If you did then did you download and install the full version or did you use the channel switcher?

If you keep having problems and removing the sessionstore.js file(s) doesn't help then create a new profile.

Create a new profile as a test to check if your current profile is causing the problems.

See:

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

more options

kerframil -- thanks, but there was no Mozilla folder in Home>Library. There was a Mozilla folder in the main Library folder on the hard drive. I followed the steps you recommended, but the unwanted tabs still appeared when I restarted Firefox.

more options

cor-el -- Not sure if app downloaded from Comcast was full version, so I went to Mozilla website and downloaded Firefox again. No results with tabs. I'll read the instructions for creating new profile and give it a try. Thanks, again.

more options

cor-el, thanks again for trying to help, but I could not complete the first step in creating a new profile -- though Firefox was not running, "Firefox unexpectedly quit" error message appeared when I hit return key after entering the required line of type in Terminal, even after restarting my computer. I give up on Firefox and am going to use Safari as my default browser.

more options

Chosen Solution

You can try to trash or remove the entire Firefox folder to force Firefox to create a new default profile.

  • /Users/<user>/Library/Application Support/Firefox
more options

It worked!! Thanks, cor-el.

more options

You're welcome