X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Trying to completely disable "this connection is untrusted" dialog

Posted

I'm trying to completely disable the "this connection is untrusted" dialog. I've had this issue since 3.5 when the security model was changed. There used to be a plugin that reduced the amount of time it took to get through this dialog, but it stopped working with 4.0.

Issues: I am a systems administrator that managages 1000's of servers & devices. A large number of these have internal websites, and they can be replaced/change frequently (HP ILO's, temporary dev websites, switches, etc.). the frequency of the turnover and the effort to create and assign a certificate to each of these websites would cause a lot more effort then going through the dialog choices. however, the dialog choices frequently slow my work down on a regular basis. Adding an excemption for each website would not work due to the frequently changing nature of my environment.

So to sum up: I want to completely and utterly turn off/remove the "this connection is untrusted" dialogs from my Firefox. It will save me (and others I would imagine) time and effort to simply disable this dialog completely. I don't care how obscure it would be to get to work, as long as it's an option and it only has to be done once.

Additional System Details

This happened

Every time Firefox opened

This started when...

firefox 3.5

Installed Plug-ins

  • IE Tab Plug-in for Mozilla/Firefox
  • ActiveTouch General Plugin Container Version 105
  • Google Talk Plugin Video Accelerator version:0.1.43.7
  • Version 2.0.7.0
  • Google Update
  • Shockwave Flash 10.2 r152
  • Garmin Communicator Plug-In 2.9.3.0
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50524.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

there is no "Error" the issue is with the inability to change the security settings that would enable me to work more efficiently.

gtinmia 0 solutions 2 answers

Instructions

   Remove Blocks for SSL Related Problems
       1
       Click the Firefox desktop icon to launch the Web browser on your computer. Alternatively, click "Start," "All Programs," "Mozilla Firefox" and then "Firefox."
       2
       Position the mouse cursor in the address bar and type "about:config" in the space. Click the green arrow at the end of the address bar or press the "Enter" key. Click the "I'll be careful, I promise!" button after the "This might void your warranty!" warning message about changing advanced settings appears on the screen.
       3
       Enter "browser.ssl_override_behavior" in the "Filter" text box. Locate the "browser.ssl_override_behavior" value in the "Preference Name" list and double-click it.
       4
       Delete the "2" value in the "Enter integer value" dialog box. Enter "1" in the dialog box and click the "OK" button.
       5
       Close the Firefox and restart it. Firefox no longer blocks access to sites with expired or unknown SSL certificates.
   Access Other Untrusted Sites
       1
       Launch Firefox on your computer as described in Step 1 of Section 1. Navigate to a website that prompts Firefox to display the "This Connection is Untrusted" warning message.
       2
       Click the "Add Exception" button at the bottom of the warning message box.
       3
       Click and enable the "Permanently Store This Exception" option. Click the "Confirm Security Exception" button. The window closes and Firefox no longer displays the warning message or blocks access to the site. You must add the exception for every untrusted site you want to browse.


Read more: How to Disable "This Connection Is Untrusted" in Firefox | eHow.com http://www.ehow.com/how_8470294_disable-connection-untrusted-firefox.html#ixzz1O1bkYCOz


http://www.ehow.com/how_8470294_disable-connection-untrusted-firefox.html

Modified by gtinmia

Helpful Reply

I appreciate your response. I've tried the ssl override behavior, but in the end your are still adding exceptions over and over again. The goal is to not have to do that. The ssl override shortens the process for sure, I'm looking for a way to completely strip it from my intranet experience.

moxivator 0 solutions 1 answers

Helpful Reply

I am so tired of firefox telling me "This Connection is Untrusted"!!!!!!!! I'm tired of having to add exceptions, I'm tired of the extra tiny lag time of loading while it checks sites, I'm tired of typing the URL I want into the URL window only to look up to see that the lag time has now caused my cursor to stop typing in the URL window and has now started searching in my Google homepage halfway through my typing!!

Firefox, GIVE US A CHOICE of whether we want secure browsing on or off or I am OFF YOU and onto another browser!!!~~!!~!~!!!~!!! Quit forcing things on us like Facebook does with no options to opt in or out if we so choose.