X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Youtube videos state: "An error occurred. Please try again later."

Posted

I was using the Firefox 4 beta for a while, and Youtube had always worked. Then when the final RC came out (or one of the last betas, don't fully remember), I immediately installed it, yet Youtube gave me the message stated above when trying to play any video. I have even tried switching to the HTML5 trial to no avail. I have been having to downgrade to the latest 3.6 version to be able to view Youtube videos.

Additional System Details

Sites Affected

https://www.youtube.com/

Installed Plug-ins

  • MacVsn 1.3.0.7279
  • npmnqmp 071705000010
  • Picasa plugin.
  • iPhoto6
  • DivX Web Player version 2.0.0.263
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 10.1 r102
  • 4.0.60129.0
  • Java Plug-In 2 for NPAPI Browsers
  • Version 2.0.4.2108
  • Google Talk Plugin Video Accelerator version:0.1.43.7
  • Shockwave Flash 10.2 r152
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adobe Contribute Toolbar
6.0
true
{01A8CA0A-4C96-465b-A49B-65C46FAD54F9}
Conduit Engine
3.3.3.2
false
engine@conduit.com
InvisibleHand
3.1.5
true
canitbecheaper@trafficbroker.co.uk
User Agent Switcher
0.7.3
true
{e968fc70-8f95-4ab9-9e79-304de2a71ee1}
Firefox Sync
1.7
true
{340c2bbc-ce74-4362-90b5-7c26312808ef}
Flagfox
4.1.2
true
{1018e4d6-728f-4b20-ad56-37578a4de76b}
F1 by Mozilla Labs
0.8.3
true
ffshare@mozilla.org
Greasemonkey
0.9.3
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
DownThemAll!
2.0.5
true
{DDC359D1-844A-42a7-9AA1-88A850A938A8}
Adblock Plus
1.3.7
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Test Pilot
1.1.1
true
testpilot@labs.mozilla.com
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
15
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.google.com/ig?hl=en&source=iglk
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
browser.tabs.autoHide
true
browser.tabs.warnOnClose
false
dom.disable_window_move_resize
true
dom.max_chrome_script_run_time
0
extensions.lastAppVersion
4.0.1
general.useragent.extra.ubiquity
network.cookie.prefsMigrated
true
network.http.pipelining
true
network.http.pipelining.firstrequest
true
network.http.pipelining.maxrequests
8
network.http.proxy.pipelining
true
places.database.lastMaintenance
1301276942
places.history.expiration.transient_current_max_pages
128849
places.last_vacuum
1301363835
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_page_delay
50
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
56
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.cpd.downloads
false
privacy.cpd.formdata
false
privacy.cpd.history
false
privacy.cpd.sessions
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.OCSP.enabled
0
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
0x22600,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce 8600M GT OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows
1/1 OpenGL

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove the Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"

Question owner

Forgot to mention that I have tried that a few different times and did not solve the problem.

I've also tried uninstalling then reinstalling the flash plugin like some have suggested when google searching, but that also did nothing to solve it.

Thanks for the reply however!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox 4 you can use one of these to start in Troubleshoot Firefox issues using Safe Mode:

  • Help > Restart with Add-ons Disabled
  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)

You can also try "Reset all user preferences to Firefox defaults" on the Troubleshoot Firefox issues using Safe Mode start window.

Modified by cor-el

Question owner

I tried all the suggested items listed and none worked. Even in safe mode youtube videos still gave the same error message in Firefox 4.0.1.

I have yet been able to compare with another Mac with Firefox 4 installed, hopefully I will be able to do that soon to see if I have anything different in the settings and such. If not, it may for some reason be a hardware issue (?) or possibly some settings in Snow Leopard that are messing it up versus it being a problem with Firefox.


  • Also installed and tried out Firefox 5 beta and same thing occurs with youtube videos.

Modified by Mook

Tribadox 0 solutions 1 answers

Allow cookies observation: If you allow cookies from "youtube.com" instead of "http://www.youtube.com" videos will play without having "accept 3rd party cookies" checked

jimmbbo 0 solutions 1 answers

Removed and reinstalled Firefox... problem solved.... Also got rid of the "another version running" flash screen on startup and updated to v13...

Modified by jimmbbo