X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I prevent firefox from updating automatically?

Posted

Firefox announces a new update is available and then goes ahead and installs it. Example: 4.01 installed and has turned off my AVG safe search add-on. It also has made it impossible to use system restore.

How do I 1. Make it impossible for Firefox to update without my permission? and 2. how do I go back to an earlier version of firefox?

Chosen solution

You're welcome.

Could you please click the "Solved It" button next to the post which solved the problem for you? This will help others searching for a solution to the same question.

Thanks.

Read this answer in context 2

Additional System Details

This happened

Every time Firefox opened

This started when...

Firefox updated itself to version 4.0.1

Installed Plug-ins

  • Macromedia Shockwave for Director Netscape plug-in, version 8.5
  • 1.7.0059.1
  • npsnapfish
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • getplusplusadobe162100
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.3 r181
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60310.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

Helpful Reply

The setting is located in the Advanced menu accessible by clicking the Firefox button, go to Options | Options | Advanced and in the Update tab, checkmark the option "Ask me what I want to do".


To revert to the previous secure version. do the following:

  1. Go to Download Firefox v3.6.17 and download it to the desktop.

  2. Then go to Add/Remove Programs, scroll down to "Mozilla Firefox" and remove it, choosing to keep your bookmarks, customizations etc., (don't checkmark the box).

  3. Then reboot and delete the folder called "Mozilla Firefox" at this location: C:\Program Files\Mozilla Firefox

  4. Finally run the installation file you downloaded to the desktop earlier.

Your bookmarks, customizations etc., are maintained in a different location and will become available to you again once you complete the installation.


After you complete the installation, go to the Plugins Check page and update where necessary.


However, before you go that route, here are a few tips to make FF4 look like the previous version.

  • Right click a blank part of the tab bar and click "Tabs on top" to remove the checkmark. Tabs will subsequently reappear below the search bar.

  • Repeat the same steps, but click the top one called "Menu bar". This will reinstate the text links at the top.

  • To rearrange the layout, repeat the same steps again and choose "Customize". A panel will open and while that remains onscreen, you can move elements like toolbars, buttons etc around and place them anywhere you wish. You can also drag anything you don't like into that panel and add anything you want by dragging it out of there.

  • To replace the status bar at the foot of the page, install this add-on: https://addons.mozilla.org/en-US/firefox/addon/status-4-evar/


N.B. AVG Safe Search blocks the use of the Enter key as a means of loading a site after you type in a URL.

Question owner

Thanks, that was a great help. I'm glad to be back on 3.6 and have everything working again. 4.1 was a disaster.

Modified by ubi51

Xircal 334 solutions 3835 answers

Chosen Solution

You're welcome.

Could you please click the "Solved It" button next to the post which solved the problem for you? This will help others searching for a solution to the same question.

Thanks.

Question owner

Solved it button returns "error in submitting your vote."

Xircal 334 solutions 3835 answers

OK, thanks for the tip. I'll pass it on.