X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Proxy Server Problems

Posted

Last week I had many viruses on my computer so it screwed a lot of stuff on my PC up, I finally got rid of them, but now whenever I start up Firefox it says "Proxy not found", it has never said that before, and every time I start it up I have to go into Network Options and tell it to auto-detect the Proxy.

I've never had this problem before, how do I fix it?

Additional System Details

This happened

Every time Firefox opened

This started when...

A couple days ago

Installed Plug-ins

  • SOE Web Installer
  • npdnu
  • npdnupdater2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 10.3 r181
  • 4.0.60310.0
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • 1.7

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Wörterbuch Deutsch (de-DE), Hunspell-unterstützt
20110321
true
de_DE@dicts.j3e.de
Panda3D Game Engine Plug-In
1.0.2
true
runtime@panda3d.org
SOE Web Installer
1.0.3.147
true
{000F1EA4-5E08-4564-A29B-29076F63A37A}
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
DownloadHelper
4.8.6
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Java Console
6.0.20
false
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
Java Console
6.0.21
false
{CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}
Java Console
6.0.22
false
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
Default Manager
2.2
false
{3252b9ae-c69a-4eaf-9502-dc9c1f6c009e}
Greasemonkey
0.9.3
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
AniWeather
0.8.16
true
{4176DFF4-4698-11DE-BEEB-45DA55D89593}
DealPly
1.0.7
false
{EB9394A3-4AD6-4918-9537-31A1FD8E8EDF}
Personas
1.6.2
true
personas@christopher.beard
Firebug
1.7.1
true
firebug@software.joehewitt.com
Modified Preferences
Name
Value
browser.history_expire_days.mirror
180
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
browser.tabs.warnOnClose
false
extensions.lastAppVersion
4.0.1
network.cookie.prefsMigrated
true
network.protocol-handler.warn-external.dnupdate
false
places.database.lastMaintenance
1305980456
places.history.expiration.transient_current_max_pages
96578
places.last_vacuum
1303691593
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Radeon X300/X550/X1050 Series (Microsoft Corporation - WDDM)
Vendor ID
1002
Device ID
5b60
Adapter RAM
Unknown
Adapter Drivers
atiumdag atiumdva atiumd64 atiumd6a atitmm64
Driver Version
8.56.1.16
Driver Date
4-25-2009
Direct2D Enabled
Blocked on your graphics driver. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled
false (6.1.7601.17563, font cache n/a)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
0/1

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You can find the connection settings in Tools > Options > Advanced : Network : Connection

If you do not need to use a proxy to connect to internet then select "No Proxy"

See "Firefox connection settings":

Question owner

I do that, but that doesn't stay the chosen option, every time I sign in, even if I turn it off before, it still says there's no proxy found.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

See:

That setting can also be changed by an extension.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Question owner

When I did Safe Mode it opened 2 tabs, the first one with a website called Safe, the second called Mode. But there were no Proxy problems. I disabled some suspicious Extensions to FireFox, but in regular startup, I still have Proxy problems.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You should place a hyphen between safe and mode (-safe-mode) and a space to separate the -safe-mode switch from the Firefox path

"C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode