X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I hate, hate, hate the new version of this firefox and the popups that are under my search bar are driving me crazy! How do I go back to what I had before?

Posted

The popups from firefox under my search bar are not a welcome addition. I can't get them to turn off going through the popup security feature.

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to the new version of firefox

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.2 r153
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

I really dislike this new version and if I can't get back to what I had before where I don't have to look at your popups under my tool bar I am changing.

Xircal 334 solutions 3835 answers

There are no popups on Firefox by default. I suspect you've installed something which has caused them, or have been hit by a so called drive-by malware download.

What I suggest you do initially is to download the free version of Malwarebytes from http://www.malwarebytes.org/products/malwarebytes_free and run a full system scan to eliminate malware as the culprit as is often the case.


Then come back to Firefox and install this Adblocker: https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/


If the problem persists, please post again in this thread.


Just noticed some plugins which are out of date and which expose your system to attack. See http://www.adobe.com/support/security/advisories/apsa11-02.html

Modified by Xircal

Question owner

So the box that is stating: "Be a web hero! Help someone you know upgrade to Firefox 4 today"! is not coming from you???

Xircal 334 solutions 3835 answers

Oh, this is indeed a stupid move by Mozilla! Here's the link: http://www.mozilla.com/en-US/firefox/webhero/

I can't think what they're trying to achieve with a childish campaign like this one.

I think if you install this add-on, it will filter this junk out: https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24401 answers

Are you referring to the "snippets" that appear on the default about:home homepage, below the Search container?

The easiest way of fixing that is to set your own choice of a homepage. Or change to the homepage that was used in previous versions of Firefox.
http://www.google.com/firefox


You can hide the box that shows the snippets with code in userChrome.css

Add code to userChrome.css below the @namespace line.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* hide snippet container on the about:home page */
#snippetContainer { display: none !important; }


You can use the ChromEdit Plus extension to have easier access to the customization files, from within Firefox.

   * ChromEdit Plus: http://webdesigns.ms11.net/chromeditp.html

<- from: /questions/822755 - c ->

Modified by cor-el

Xircal 334 solutions 3835 answers

Just change the home page to a regular google site.

  • Go to http://www.google.com.

  • Click the orange Firefox button and go to Options | Options | General
  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

Modified by Xircal