X
Tap here to go to the mobile version of the site.

Support Forum

Firefox will not keep my homepage setting but will default to a fake google homepage when the browser is reset. What's going on ?

Posted

Every time I set my homepage and reset the browser it will go to a generic replica of google or another unrecognizable site. How do I fix this?I've tried reinstalling but that doesn't work either.

Every time I set my homepage and reset the browser it will go to a generic replica of google or another unrecognizable site. How do I fix this?I've tried reinstalling but that doesn't work either.
Xircal 334 solutions 3835 answers

Sounds like a browser hijacker is on the loose.

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the orange Firefox button and go to Options | Options | General

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/


After you complete the above steps, download the free version of Malwarebytes from http://www.malwarebytes.org/products/malwarebytes_free and run a full system scan to eliminate malware as the culprit as is often the case.

Sounds like a browser hijacker is on the loose. To revert to Google as your preferred search engine, please do the following.<br><br> * In the location bar, type '''about:config''' and hit Enter.<br><br> * In the filter at the top, type: '''keyword.URL'''<br><br> * Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=<br><br> The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing. ---- '''To reset your home page, do the following'''.<br><br> * Go to the site you want to set as your homepage.<br><br> * Click the orange Firefox button and go to '''Options '''| '''Options '''| '''General''' <br><br> * Make sure it says "''Show My Homepage''" in the first dropdown menu.<br><br> * Click the button called "'''Use Current Pages'''" to set the homepage to the one you have on the screen.<br><br> After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/ ---- After you complete the above steps, download the free version of Malwarebytes from http://www.malwarebytes.org/products/malwarebytes_free and run a full system scan to eliminate malware as the culprit as is often the case.