Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I try to load juno.com from FF, it says "loading jimandamy2" (our email) forever and never connects. Internet Explorer loads the site without problem, Any help?

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by cor-el

more options

Initially, FF worked fine and I was delighted. Then it stopped and I do not have a reason why. You are welcomed to call during the workday with questions. phone number removed by a moderator for privacy reasons in a public forum - we don't do support by phone

Initially, FF worked fine and I was delighted. Then it stopped and I do not have a reason why. You are welcomed to call during the workday with questions. ''phone number removed by a moderator for privacy reasons in a public forum - we don't do support by phone''

Modified by the-edmeister

All Replies (2)

more options

Do any websites load? Or is that a problem with just that one website?

more options

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove the Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

In Firefox 4 you can use one of these to start in Diagnose Firefox issues using Troubleshoot Mode:

  • Help > Restart with Add-ons Disabled
  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)