Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is not recognising that its upgraded to firefox 4

more options

Upgraded to firefox 4 and tried to add some persona's but firefox tells me im still on 3.5 and therefore cant add them, check about firefox info and defo on firefox 4, cleared cache etc, shut down laptop and rebooted but still the same.

Chosen solution

This is typically caused when an add-on changes the user agent string (identifies the version of Firefox). To rectify this you can reset your user agent string.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click on it and select Reset, this will set the user agent string back to the default in Firefox 4

There are other user agent string settings that may have been modified, but these are no longer used in Firefox 4. You can reset them if you want, for details see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

This is typically caused when an add-on changes the user agent string (identifies the version of Firefox). To rectify this you can reset your user agent string.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click on it and select Reset, this will set the user agent string back to the default in Firefox 4

There are other user agent string settings that may have been modified, but these are no longer used in Firefox 4. You can reset them if you want, for details see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser

more options

Thank you, done and working.