X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Newest upgrade is not compatible with Mac10.4.11. Hate the warnings when I can't do anything about it. Suggestions?

Posted

I have downloaded newest version but it will not operate on eMac 10.4.11. Are there any alternatives that will provide adequate security?

Additional System Details

This happened

Just once or twice

This started when...

I attempted to install new version

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Netscape Navigator Default Plug-in
  • Shockwave Flash 10.1 r53
  • Java 1.3.1 Plug-in (CFM)
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java 1.3.1 Plug-in
  • Macromedia Shockwave for Director Netscape plug-in, version 10.1.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Firefox 4 requires at least OS X 10.5 and an Intel Mac. There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

If you prefer, you can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html