Search Support

In earlier versions, the URL Bar had this feautre where you could type in certain key words or phrases and it would take you to the relevant site directly, much like Google's "I'm feeling lucky" feature.

  • 3 replies
  • 27 have this problem
  • 42 views
  • Last reply by Helper7677

more options

Say for example you typed in "wiki democracy" in earlier Firefox versions it would directly take me to http://en.wikipedia.org/wiki/Democracy

But now it gives me a ordinary Google search http://www.google.co.in/search?q=wiki+democracy&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

Another example would be say type in "imdb shawshank". Earlier: http://www.imdb.com/title/tt0111161/ Now: http://www.google.co.in/search?q=imdb+shawshank&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

I hope you see how the earlier feature was neater and better.

Chosen solution

There is a change in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site

To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference.

  1. Type about:config into the location bar and press the Enter key
  2. If you see a warning, accept it (promise to be careful)
  3. A list of preferences will open
  4. Filter = keyword.URL
  5. Double-click on that preference in the lower pane
  6. A small window will appear; copy one of the URLs below and paste into the box in that small window (or type it into the box in that window exactly as shown below):

Instead of the above, you could install this extension:

See:




You need to update the following. The Plugin version(s) shown below was/were submitted with your question and is/are out of date. You should update to avoid known security issues with the version(s) you have installed. Click on "More system info..." to the right of your question to see what was included with your question.

  • Shockwave Flash 10.2 r159 (security update version 10.3.181.14 released 2011-05-12)
  1. Check your plugin versions on either of the following links':
  2. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.
Read this answer in context 👍 10

All Replies (3)

more options

Chosen Solution

There is a change in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site

To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference.

  1. Type about:config into the location bar and press the Enter key
  2. If you see a warning, accept it (promise to be careful)
  3. A list of preferences will open
  4. Filter = keyword.URL
  5. Double-click on that preference in the lower pane
  6. A small window will appear; copy one of the URLs below and paste into the box in that small window (or type it into the box in that window exactly as shown below):

Instead of the above, you could install this extension:

See:




You need to update the following. The Plugin version(s) shown below was/were submitted with your question and is/are out of date. You should update to avoid known security issues with the version(s) you have installed. Click on "More system info..." to the right of your question to see what was included with your question.

  • Shockwave Flash 10.2 r159 (security update version 10.3.181.14 released 2011-05-12)
  1. Check your plugin versions on either of the following links':
  2. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.

Modified by Helper7677

more options

Thanks a lot! Your solution has solved the problem.

more options

esskaygee:

You are welcome. Glad I was able to help.

So that other users can find solutions to previously asked Firefox support questions, please take a couple of minutes to return to the forum, sign in and click "Solved" next my answer. Thanks.