Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I no longer have a mail icon. I do not know how to get to my mail. I also can no longer tell IF I have mail. I am not a computer person and I am very upset that you would have me "upgrade" without warning me that this would happen.

  • 20 replies
  • 44 have this problem
  • 664 views
  • Last reply by silkphoenix

more options

I don't have a mail button anymore.

Chosen solution

I am glad. Now could you please click SOLVED so other users can view this post in the future for reference?

Thank you.

Read this answer in context 👍 0

All Replies (20)

more options

Firefox hasn't had a "mail icon" since like Firefox 1.5, back in 2006. Whatever you were using was an Add-on or Extension.

There is a warning during the upgrade process about add-ons being disabled due to lack of compatibility, plus you're given a dialog box that lists the specific add-ons that aren't compatible with the new Firefox version.

{ Ctrl + Shft + A } and look at the Extensions list to see which Extensions are disabled as Not compatible with Firefox 4.0.1. Right-click those extensions and select Find Updates. If an update isn't loaded, that extension might have been abandoned by whoever created it. In that case you'll need to locate and install a different extension with the features you want.
https://addons.mozilla.org/en-US/firefox/search/?q=Mail&cat=all&x=0&y=0

more options

Would this be the add-on you might have installed:

https://addons.mozilla.org/en-US/firefox/addon/webmail-notifier/


If it is still on your list, it should appear in your Add-on bar in the bottom of the screen: View > Toolbars and CHECK the Add-on Bar.

more options

I am not a computer person. I don't understand how this works. There is no add on bar. According to the link given by the-edmeister (Cont + Shift + A) I can also no longer use my printer or Skype. I feel like my computer is now garbage. I had to get someone to connect me to my email page, then bookmark that, just so I can find my mail. All the things I use the most are gone.

more options

The Add-on Bar is a bar in the bottom of the browser (screen) all across. If there's nothing there, try this:


View > Toolbars and CHECK the Add-on Bar


To see your Extension List, try this:

Tools > Add-ons

and then CLICK on the Second item on the left (Extensions). If you have any add-ons installed, you should see them listed in the window on the right. Do you see any? If so, does any of them have the name like "mail" or close to that?

Please let us know.

more options

The add-on bar was already checked in View. There are no add ons. On the extension list, there in nothing that says mail.

more options

OK, I figured out that you are using Yahoo Mail.

After you log-into your Yahoo Mail, do you see a "Messenger" underneath the Yahoo logo (top left)? If you do, do this: Click "messenger" -> preferences -> alerts and sounds. Go to the choice box (on the right side), click "enable" -> If you want sound: click "I receive a message in my Yahoo Mail" -> choose the sound you want to hear (or click the box "display box dialogue"). After you're done click "okay".


If you do not have Messenger under the Yahoo logo, you can use this add-on:

https://addons.mozilla.org/en-us/firefox/addon/yahoo-mail-notifier/


If you don't know how to install this add-on, let us know.

more options

OK, now I have an envelope that tells me when I have new mail, but it won't take me to the mail page.

more options

When you click on the envelope, anything happens?

more options

OK - it will take me to mail IF there is a number next to the envelope, but I can't get to mail with it unless there is a number.

more options

That's only a email notification. I don't use Yahoo Mail much so I am not familiar with how the notification works. Maybe you cannot use it to go to your mail box unless you have new emails. Since you have your mail box bookmarked, you can use that to open your mail box when there's no email.

How did you get to your mail box in the past before this problem exist?

more options

I clicked on the envelope icon at the top of the page.

more options

Try this to see if it helps:

Tools > Options > Privacy > Make sure "Use Custom Settings...." is on the window, if not, choose it from the drop-down menu. Then CLICK "Show Cookies" and put in Yahoo in the SEARCH space. CHECK all the boxes that shown in the window and then click REMOVE COOKIE. Then OK and exit the Options window.

Try to click on the envelope to see if it brings you to the mail box.

more options

There are no boxes. I tried REMOVE COOKIE and it took the first thing off the list. Not all the things say yahoo.

more options

Did you type "YAHOO" in the Search box? Once you did, anything appear?

more options

I typed yahoo in the search box. A lot of things appeared, but there were no boxes to click. Most of the things did not say yahoo.

more options

You didn't see "mail.yahoo.com" in the list? See the screenshot underneath:

more options

there are 3 of them - no boxes to click

more options

I am sorry, I don't mean boxes. Please just highlight them and remove them all.

more options

It worked! Thank you.

more options

Chosen Solution

I am glad. Now could you please click SOLVED so other users can view this post in the future for reference?

Thank you.