X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Flash doesn't work

Posted

Flash content doesn't work at all in firefox 4.01 on my mother's computer. All flash content either is just blank or a solid colored (usually black or white) box. For example on Youtube, the videos just show up as black boxes. On face book the game windows are either blank or a solid colored box. Mostly it is just blank where the flash content should be. Flash works completely fine in Both I.E. and Chrome.

The problems started in the latest version of Firefox 3. The flash pugin container was crashing a lot. Like multiple times in an hour. Then it just stopped working as explained above. After I tired un-installing the flash player and plugins and reinstalling them with out success, I tried upgrading to Firefox 4.01. This didn't fix the problem either so I tried removing the flash player and plugins and re-installing them again. This didn't work so I completely un-installed Firefox 4.01, making sure to delete all the files in the appdata folder as well. Then I un-installed every thing having to do with flash. After this was done I reinstalled Firefox 4.01 and the flash player/plugins. This still did not fix the problem.

I have made sure the firewall is not blocking the plugin container and have even completely disabled it. I have also tried turning off hardware acceleration in the flash player, updating the graphics card drivers, running Firefox in safe mode, making a new Firefox profile, deleting all the cookies,history,cache ect., and using an extension called better privacy (http://netticat.ath.cx/BetterPrivacy/BetterPrivacy.htm) to delete the flash cookies. None of it has helped.

Additional System Details

This happened

Every time Firefox opened

This started when...

About a week ago

Installed Plug-ins

  • Garmin Communicator Plug-In 2.9.3.0
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • np-mswmp
  • Adobe Shockwave for Director Netscape plug-in, version 10.3
  • 1.7.0069.3
  • 6.0.12.46
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • npdivxplayerplugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Foxit Reader Plug-In For Firefox and Netscape
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • Shockwave Flash 10.2 r159
  • Delivery Network Acceleration by BitTorrentâ„¢
  • DivX Web Player version 2.0.3.4
  • DivX VOD Helper Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60310.0
  • NPWLPG
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Google Update
  • Version 0.8.6c, copyright 1996-2006 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

See http://kb.mozillazine.org/Flash#Performance_or_display_issues_with_certain_Flash_videos which sounds like the problem your mother is experiencing.

Helpful Reply

Thanks but as I said in my question I have already disabled the hardware acceleration for flash and updated the video drivers.

Xircal 334 solutions 3835 answers

Yes, I realize that, but there's more info on that site which describes other causes.

Question owner

I have already read the page several times and it doesn't have anything that helps.

Modified by Josh885

LoriH57 1 solutions 25 answers

I too have read that page over and over and tested my flash by going to the adobe website and nothing works. I have the latest version of everything, yet nothing I do makes the flash movie work in Firefox. I am a web designer and have never had this problem until recently. The flash movie works in IE, Chrome, Safari and even in Netscape, but not in FF. I've asked no less than a dozen people to test it for me and it doesn't work for them in FF either. The player is visible and the image titles change as if the photos were showing, but the window is blank in FF. It also does not loop continuously, as it should in FF. It does in all the other browsers. The images I've attached are from the test example I was making for my client. As you can see, the left one shows the images just fine in Chrome (and is the same in other browsers. The right side image from FF, clearly shows there is nothing showing within the flash window on that page.

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24448 answers

URL of that web page?

LoriH57 1 solutions 25 answers

http://lori-h.com/MsDenver/JBpaintingsTest1.html (BTW, I know the links on the left don't work. They aren't supposed to be working at this point).

Modified by LoriH57

LoriH57 1 solutions 25 answers

Is there an email address to contact FF/Mozilla directly about this?

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

That is caused by hotlink protection on the server.

Firefox doesn't pass the referrer to the Flash plugin and the server refuses to send the image files because of that.

http://lori-h.com/MsDenver/slides/p_0001.jpg
GET /MsDenver/slides/p_0001.jpg HTTP/1.1
Host: lori-h.com
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
Connection: keep-alive

HTTP/1.1 403 Forbidden
Date: Tue, 07 Feb 2012 23:05:01 GMT
Server: Apache
Content-Length: 347
Keep-Alive: timeout=15, max=98
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1
LoriH57 1 solutions 25 answers

Ok, I'll contact my server, but why then, does it work on other sites I've created using the exact same server? I'm just curious. This only started happening recently. I checked the other sites and they are still operating just fine in FF. I also compared the permissions and they are identical. As I said, I will contact my server, but I don't understand why one doesn't work when all the others do. Thanks!

Modified by LoriH57