X
Tap here to go to the mobile version of the site.

Support Forum

When I open a new tab it does not open with my default browser but the security programs browser how do i change this?

Posted

My Security / AntiVirus program appears to have added a search bar into Firefox. When i open a new tab in Firefox 4 it opens with this as the default search engine and not my favourite Google which is set up when I open firefox. How can i change this or remove the security/antivirus search bar?

Thanks grjones

My Security / AntiVirus program appears to have added a search bar into Firefox. When i open a new tab in Firefox 4 it opens with this as the default search engine and not my favourite Google which is set up when I open firefox. How can i change this or remove the security/antivirus search bar? Thanks grjones

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.2 r159
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60310.0
  • NPWLPG
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

Please do the following.


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.

EDIT: If the Search engine is AVG Security Toolbar, follow instructions here to disable it in addition to the above steps: http://free.avg.com/ww-en/faq.num-2948#tba5


To reset your home page, do the following.


  • Go to the site you want to set as your homepage.
  • Click the orange Firefox button and go to Options | Options | General (Firefox 4.0.x and above).
  • Go to Tools | Options | General (Previous version of Firefox).
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.
Please do the following. * In the location bar, type '''about:config''' and hit Enter. * In the filter at the top, type: '''keyword.URL''' * Double click it and remove whatever's in there and replace it with http://www.google.com/search?q= The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "''Copy Link Location''" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing. '''EDIT''': If the Search engine is AVG Security Toolbar, follow instructions here to disable it in addition to the above steps: http://free.avg.com/ww-en/faq.num-2948#tba5 ---- '''To reset your home page, do the following'''. * Go to the site you want to set as your homepage. * Click the orange Firefox button and go to '''Options '''| '''Options '''| '''General '''(Firefox 4.0.x and above). * Go to '''Tools '''| '''Options '''| '''General''' (Previous version of Firefox). * Make sure it says "''Show My Homepage''" in the first dropdown menu. * Click the button called "'''Use Current Pages'''" to set the homepage to the one you have on the screen.

Modified by Xircal

Question owner

Brilliant. Thanks

Brilliant. Thanks
Xircal 334 solutions 3835 answers

You're welcome.

To prevent a recurrence, install this add-on: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

Could you also please click the "Solved It" button to take your post out of the loop?

Thanks.

You're welcome. To prevent a recurrence, install this add-on: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/ Could you also please click the "Solved It" button to take your post out of the loop? Thanks.