X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot change search engine or restore default

Posted

I am unable to change, add, remove my search providers.

I have tried safe mode and have tried resetting them by way of the search engine.

I am running FirFox 4.1

Additional System Details

This happened

Not sure how often

This started when...

Unsure

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.3
  • Shockwave Flash 10.2 r159
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60310.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Version 0.9.18, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • Version 1.1.8, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

Helpful Reply

To revert to Google as your preferred search engine, please do the following.


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.



To reset your home page, do the following.


  • Go to the site you want to set as your homepage.
  • Click the orange Firefox button and go to Options | Options | General
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

Modified by Xircal

Question owner

Thanks, but my issue is with the search box in the top right of screen - not the default search or homepage. This did not help.

Question owner

I had to remove entries from the registry to restore firefox to a blank slate.

glenn6990 0 solutions 1 answers

Justern, I have the same problem - I want to change the default search engine in the top right of the toolbar. Did you get a useable answer to your question?

Modified by glenn6990