On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Had to revert to 3.6. Version 4.o would just sit a with the loading web page icon spining. 4.0 is 6X slower on my machine.

  • No replies
  • 1 has this problem
  • 5 views
more options

Inspirion laptop. 2.8Ghz dual core pentium processor, 2mb ram, Windows Vista SP2 Upgraded to FF 4.0 this morning. Launched the new FF and could barely get a web page-----any web page to load. FF would just sit there with the loading web page icon spinning until I canceled the loading process and tried to reload the page numerous times. I deleted the browsing history and cache with no luck. Reverted back to 3.6 and no problems, sites load without all the drama. Don't know what the problem was but I spent all morning installing and then reverting. I'm not badmouthing FF like others have, but I will read the forum posts to be sure that new versions work before I upgrade again.

Inspirion laptop. 2.8Ghz dual core pentium processor, 2mb ram, Windows Vista SP2 Upgraded to FF 4.0 this morning. Launched the new FF and could barely get a web page-----any web page to load. FF would just sit there with the loading web page icon spinning until I canceled the loading process and tried to reload the page numerous times. I deleted the browsing history and cache with no luck. Reverted back to 3.6 and no problems, sites load without all the drama. Don't know what the problem was but I spent all morning installing and then reverting. I'm not badmouthing FF like others have, but I will read the forum posts to be sure that new versions work before I upgrade again.