X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't install add-ons because cannot modify the needed file

Posted

This happening on a Mac with Firefox 4. I tried many plugins and had the same problem trying to install everyone. I was able to download personas with no problem. My Mac is up to date with all the latest software. Using 4.0.1 Firefox which appears to be up to date. With the previous version of Firefox I had no problem downloading plugins.

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-in Version 2.9.3.0
  • iPhoto6
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 4.0.51204.0
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.2 r152

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
LastPass
1.73.0
true
support@lastpass.com
Garmin Communicator
2.9.3
true
{195A3098-0BD5-4e90-AE22-BA1C540AFD1E}
Firefox Sync
1.7
true
{340c2bbc-ce74-4362-90b5-7c26312808ef}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days
180
browser.history_expire_days.mirror
180
browser.history_expire_days_min
10
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
browser.tabs.tabMaxWidth
250
browser.tabs.tabMinWidth
100
browser.tabs.warnOnClose
false
dom.disable_window_flip
false
extensions.lastAppVersion
4.0.1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1304728121
places.history.expiration.transient_current_max_pages
124822
places.last_vacuum
1303434871
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_page_delay
50
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
17
print.print_unwriteable_margin_left
17
print.print_unwriteable_margin_right
17
print.print_unwriteable_margin_top
17
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
3
security.warn_viewing_mixed
false
Graphics
Adapter Description
0x22600,0x24300,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows
2/2 OpenGL

ryanjhouse 0 solutions 1 answers

Simply create a *NEW* profile with Profile Manager for Firefox using this flag

/Applications/Firefox.app/Contents/MacOS/firefox-bin -profilemanager

this is from the Mozilla KB http://url.thoh.us/ry4I6b

PurpleSage 0 solutions 1 answers

I'm having the same issues with FX 8 and FX 9b2 running under XP SP3. Is it the same issue as described above? If so, does the reply still apply?

Thanks for any help.

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

That is a problem with a missing unpack flag in the file install.rdf in the extensions .xpi (ZIP) archive.