X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I cannot change my homepage. It has automatically changed itself to some other search engine. The worse part is it won't permanently change in the settings either.

Posted

I should mention I downloaded an application called "savevid" to download youtube videos the other day, and I believe this is when the problem began. I uninstalled the program and I still cannot change my homepage.

Suggestions?

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.2 r153
  • GEPlugin
  • 4.0.60310.0
  • Office Live Update v1.3
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

Helpful Reply

Please do the following.


  • In the location bar, type 'about:config' and hit Enter.
  • In the filter at the top, type: 'keyword.URL'
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=
  • Close the about:config tab.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.


  • Go to the site you want to set as your homepage.
  • Click the orange Firefox button and go to Options | Options | General
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.
pmorris49 0 solutions 2 answers

I thought I had cracked it. Changed keyword url and homepage to the one I wanted, namely uk.msn. It all worked fine, unfortunately after switching off and then restarting I was back to to the wrong start page. Both keyword url and homepage had changed. Ant other suggestion would be much appreciated.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

See:


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Xircal 334 solutions 3835 answers

Install this add-on to prevent hijacking: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

pmorris49 0 solutions 2 answers

Thanks for all the advice. Unfortunately the problem still remained. The web site is 'searchqu.com'. However, I have effectively solved the problem. I went to 'Tools', 'options', 'content', 'load images automatically' and under 'exceptions' blocked it. This seemed to have worked .

Xircal 334 solutions 3835 answers

It seems to be an Israeli search engine: http://whois.domaintools.com/207.232.22.60

I'd recommend you install this add-on to prevent another search engine from deleting or modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

See these threads about searchqu: