X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I go back to the last version of 3.0?

Posted

Version 4 is hanging up evidently due to scrip errors. Additionally, I prefer the layout of the previous version.

Chosen solution

Well, first of all, here are instructions on how to downgrade the previous secure version.

Go to Download Firefox v3.6.17 and download it to the desktop.

Then go to Add/Remove Programs, scroll down to Mozilla Firefox and remove it, choosing to keep your bookmarks, customizations etc., (don't checkmark the box).

Then reboot and delete the folder called Mozilla Firefox at this location: C:\Program Files\Mozilla Firefox

Finally run the installation file you downloaded to the desktop earlier.

Your bookmarks, customizations etc., are maintained in a different location and will become available to you again once you complete the installation.

After you complete the installation, go to the Plugins Check page and update those if necessary.


Now then... you can make FF4 look like 3.6.17 very easily. Simply right click a blank part of the tab bar and click the top option called "Menu bar" to get the text links at the top again. The orange Firefox button will disappear and you'll get the old style layout back again. Personally, I prefer that one myself too. See screenshot for a comparison of the two on my own setup.

To move tabs to the previous location below the address bar, click "Tabs on top" in the same menu to remove the checkmark.

You can customize the layout to your own liking by clicking Customize in the same menu. A panel will open where you can drag buttons and toolbars you don't like into that. Similarly, you can drag anything out of there and place it wherever you like.

Also, while that panel is open, you can move the layout around, add spaces or horizontal dividers between buttons etc.

If you feel you'd like to stick with FF4 after all, could you please indicate what you're doing which produces the script errors and we'll do our best to help you.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.2 r153
  • Garmin Communicator Plug-In 2.9.3.0
  • np-mswmp
  • Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • 1.7.0069.3
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • DivX Web Player version 1.4.2.7
  • npdivxplayerplugin
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • 12.0.1.609
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Garmin Communicator Plug-In 2.6.4.0
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60310.0
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

Chosen Solution

Well, first of all, here are instructions on how to downgrade the previous secure version.

Go to Download Firefox v3.6.17 and download it to the desktop.

Then go to Add/Remove Programs, scroll down to Mozilla Firefox and remove it, choosing to keep your bookmarks, customizations etc., (don't checkmark the box).

Then reboot and delete the folder called Mozilla Firefox at this location: C:\Program Files\Mozilla Firefox

Finally run the installation file you downloaded to the desktop earlier.

Your bookmarks, customizations etc., are maintained in a different location and will become available to you again once you complete the installation.

After you complete the installation, go to the Plugins Check page and update those if necessary.


Now then... you can make FF4 look like 3.6.17 very easily. Simply right click a blank part of the tab bar and click the top option called "Menu bar" to get the text links at the top again. The orange Firefox button will disappear and you'll get the old style layout back again. Personally, I prefer that one myself too. See screenshot for a comparison of the two on my own setup.

To move tabs to the previous location below the address bar, click "Tabs on top" in the same menu to remove the checkmark.

You can customize the layout to your own liking by clicking Customize in the same menu. A panel will open where you can drag buttons and toolbars you don't like into that. Similarly, you can drag anything out of there and place it wherever you like.

Also, while that panel is open, you can move the layout around, add spaces or horizontal dividers between buttons etc.

If you feel you'd like to stick with FF4 after all, could you please indicate what you're doing which produces the script errors and we'll do our best to help you.

Modified by Xircal

Xircal 334 solutions 3835 answers

Helpful Reply

For some strange reason, the screenshot just moved on the forum.

Modified by Xircal

Question owner

The script error happened while reading a story on the Fox News page. The page froze for a while then was working then froze again when I tried to go back to another page.

Xircal 334 solutions 3835 answers

Could you update the following plugins first of all because not only are they a security risk, - see http://www.adobe.com/support/security/advisories/apsa11-02.html - they also influence the way FF behaves.

Update Flash via http://get.adobe.com/flashplayer/ Update Shockwave For Director via http://get.adobe.com/shockwave/ Update Adobe Reader by clicking the desktop icon, then Help | Check For Updates

If that doesn't fix the problem, try running Firefox in Troubleshoot Firefox issues using Safe Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.

gooshlem 0 solutions 1 answers

This is not exactly a reply, but a kind of continuing of the question. When I click on firefox, instead of it opening up I get this message: "SQlite Version Error The application has been updated, but your version of SQlite is too old and the application cannot run."

Is there any way I can get the "application" to go back to the way it was before iit was "updated". I never touched it. It must have updated itself! And when I go to Firefox it says that my computer is too old. It is not as old as plenty of other computers. It is a mac OS X 10.4.11

Please help!