X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox default start page uses facemoods search engine instead of google

Posted

Hi, I have issue with Firefox. Today I’ve notice that when I’m using search option on default Firefox 4.0 start page (about:home), results are displayed with Facemoods search engine instead of Google. I have uninstalled Facemoods from system and Firefox, yet it didn't work.

Chosen solution

There have been reports about Ask and Yahoo getting set as the search engine for the about:home "search container".
https://support.mozilla.com/en-US/questions/769519 - trustnoone's posting
Try resetting those two prefs and see what happens.

Type about:config in the URL bar and hit Enter.
If you see the warning, you can confirm that you want to access that page.

browser.startup.homepage_override.buildID
browser.startup.homepage_override.mstone
Right-click each one and select Reset.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Gadu-Gadu Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Google Update
  • Shockwave Flash 10.2 r159
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.50917.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

jscher2000
  • Top 10 Contributor
2387 solutions 21095 answers

Helpful Reply

I haven't heard of this one before. The uninstall must have left behind a few settings.

The page corresponding to "about:home" must be set in a hidden preference. You can search for and reset it using the about:config feature.

(1) Type or page about:config in the address bar and press Enter (click the button promising to be careful, and please be careful)

(2) In the filter box, type or paste facemoods and pause while Firefox searches

(3) The bolded lines show changes from the original Firefox setup. Some you might want to save, but mostly you would want to reset them to default. Right-click each one you want to change and choose Reset.

This blog post describes an additional fix for the address bar search feature if you use that: Fly With Me: Remove Facemood From Firefox.

Finally, I found a very long cleanup guide on the Spybot S&D forums which might be useful if the above doesn't solve it: Manual Removal Guide for Toolbar.Facemood - Safer-Networking Forums.

Does it work?

Modified by jscher2000

Question owner

Thanks, but unfortunately it didn't work

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24452 answers

Chosen Solution

There have been reports about Ask and Yahoo getting set as the search engine for the about:home "search container".
https://support.mozilla.com/en-US/questions/769519 - trustnoone's posting
Try resetting those two prefs and see what happens.

Type about:config in the URL bar and hit Enter.
If you see the warning, you can confirm that you want to access that page.

browser.startup.homepage_override.buildID
browser.startup.homepage_override.mstone
Right-click each one and select Reset.

Question owner

Thank you very much!

El_Rulero 0 solutions 1 answers

When I restart Firefox, it uses facemoods as search engine again and both browser.startup.homepage_override.buildID and browser.startup.homepage_override.mstone keep changing from default to user set

browser.startup.homepage_override.buildID changes value to "20110413222027" and browser.startup.homepage_override.mstone to "rv:2.0.1"

Majestic12 0 solutions 3 answers

I have the same problem and literally nothing can solve this. Maybe facemoods modified Firefox' files?

Jonny 0 solutions 1 answers

Helpful Reply

This should work:

Type about:config in the URL bar and hit Enter. If you see the warning, you can confirm that you want to access that page.

Right-click each one of these and select Reset.

browser.startup.homepage_override.buildID browser.startup.homepage_override.mstone browser.search.selectedEngine browser.search.defaultenginename

(the last two will containt 'Facemoods Search' or similar)

bren0102 0 solutions 1 answers

Worked! Thank you very much!

LCOMP 0 solutions 1 answers

Hi, I had the same problem, Try right-clicking on your search bar and you should get 'edit search engines'. There you can reset your default search engine and delete facemoods. Hope this helps!