Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why is autocomplete not working in firefox 4? the help no longer relates to the tabs. this means lots of typing when i am used to not doing any

  • 24 replies
  • 137 have this problem
  • 178 views
  • Last reply by xc800can

more options

the auto complete is not working on some sites eg hotmail login in v4. it used to work in all sites in 3.6 and earlier. the help page no longer repesents the reality of options/privcy/action field. is this a firefox or hotmail and ebay and paypal problem?


regards

All Replies (20)

more options

Hotmail uses JavaScript to create the log in form and there you can only store the name via remember form data.

Some sites like PayPal, Yahoo, Windows Live and bank sites use autocomplete="off" to prevent Firefox from saving and filling the name and the password.

If a site uses autocomplete="off" then look at this article for a bookmarklet to remove that autocomplete attribute and Firefox will offer to store the name and password.

more options

Thank you for reply. i' m not sure it helps though. its not the storing off passwords thats the proble. it is that taking hotmail as an example, in 3.6 the sigh the page used to remember the text of my email acounts. i never had remember me enabled, and i don't want it to save my password. i would just simply rember the text typed in the user name bit. very suddenly it does not do that any more in v4. thank you for trying though

more options

You can check if form data is remembered if that is what you are looking for.

more options

hi again cor- el,

thanks for your further help. im not sure if i have a bad install of firefox as i dont have those options in v4. i only have remember history under privacy. theimage below will confirm this. do you have any thoughts?

more options

Since being updated to FF4.0.1 today (when all previous form data was wiped) I've tried all versions of this setting and regular form data is NOT being remembered. I am still prompted if I want to save a password.

more options

To see all the History and Cookie settings, select:

  • Tools > Options > Privacy > History: Firefox will: "Use custom settings for history"
more options

thank you for reply cor-el. i have tried using the cutom stting you suggested, however there were no ncorrect settings and it has not solved the issue. do you have any furher suggestions? it was only the form entry memory that makes me use firefox rather than google, so if we cant slove this i will have to go to google. regards

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


In Firefox 4 you can use one of these to start in Diagnose Firefox issues using Troubleshoot Mode:

  • Help > Restart with Add-ons Disabled
  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)
more options

good morning cor-el. thanks or the safe mode idea. it has not made any difference though. am i just going to have to accept the fct that the feature no longer works?

more options

It is possible that there is a problem with the file that stores the "Saved Form" data.

Rename or delete formhistory.sqlite (plus formhistory.sqlite-journal and formhistory.sqlite.corrupt and formhistory.dat, if they exist) in the Profile Folder in case there is a problem with the file that stores the "Saved Form" data.

This will remove all saved form data, so you may want to rename formhistory.sqlite to formhistory.sqlite.sav or move the file to another folder in case you need to recover some saved data.

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

You can try to create a new profile as a test to check if your current profile is causing the problems.

See:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

more options

hi cor-el. thanks for the suggestions. i have tried every one of them and so far nothing is woking in either normal or safe mode. should i just give up trying?

more options

Did you try the bookmarklet in case websites use the autocomplete="off" attribute?

more options

yes i tried that too corel. i think we are just going to have to give up on this one. if you ever solve the issue for the other 21 of us it would be good to know how you do it

more options

Here's the solution I came up with:

Download the 3.6 version and install it. My autocomplete is now working again. I hate it when an "UPDATE" takes away features I have come to rely on!

Now if I can just figure out how to put the HOME and REFRESH icons back where they belong on the left side I"ll be happy again.

more options

Good morning yyz0. Sorry for the slight delay in geting back to you. Your solution of rolling back to 3.6 works for me too. Thanks for pointing out the option. My refresh button are back to their original positions inn my roll back. I'm not too sure why yours should be different. Is there any response from support on what went wrong in v4?

Have a great day

more options

I did figure out how to move the buttons back where I wanted them so now all is good. When I find that they have fixed the missing Autocomplete in V4 then I'll upgrade again, till then I'm sticking with what works even if it's an older version.

more options

thanks for the advice yyz. i think i will do the same thing. good luck for staying streaa free while the fix happens!

more options

When I go to a website that requires a Username/Password I want to be logged in automatically.

FireFox has remembered my Usernames/Passwords but does not use them to log me in to the sites.

I have checked at Tools/Options/Security/Saved Passwords and they are all there.

How do I get the FireFox to use them and log me in ?

more options

Make sure that you not run Firefox in (permanent) Private Browsing - Use Firefox without saving history mode.

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Permanent Private Browsing mode"

Websites remembering you and automatically log you in is stored in a cookie.

  • Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.
  • In Private Browsing - Use Firefox without saving history mode all cookies are session cookies that expire if that session is ended, so websites won't remember you.

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

more options

I'm unsure if my issue is with a particular website or FF 4. On a game site I have multiple log-ins, which are email addresses. When I log-in I always see 2 of the 6 addresses I have entered. It won't recall more than those two!? I'm going to try downgrading to 3.6 because in general I do feel 4 recalls less info, but I am not 100% certain. This is an interesting thread though. Thank you cor-el for the tips!

  1. 1
  2. 2