Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In the new Firefox 4, what happned to the save tabs and quit feature, is there a way i can still use this function?

  • 1 reply
  • 49 have this problem
  • 14 views
  • Last reply by Helper7677

more options

I just downloaded Firefox 4 and i had a problem about my Norton spy-ware toolbar not being compatible, but anyway the most important thing that makes me pick Firefox over any other web browser is that i am able to save tabs and then exit. I think this was the greatest things because i could leave turn my laptop off and save power and when i got back i cold resume what i as doing. My question is just will you ever have this save tabs and exit function again or at least a way people would turn the function on by will.

Chosen solution

One of the changes in Firefox 4: by default Firefox 4 does not display the "Save Tabs and Exit" warning message when closing multiple tabs, but it can be turned back on by changing some preferences.

  • Saving tabs was not removed from Firefox 4, but it works a bit differently.
  • By default, Firefox 4 will not ask to save tabs, but instead it will always save your tabs on exit unless you are in Private Browsing mode. You can restore them next time by:
    1. clicking Firefox button > History >"Restore Previous Session", or
    2. type about:home in the URL bar and press the Enter key, then press the "Restore Previous Session" button
  • Note: This was a decision by the developers. On this forum, we are all uncompensated volunteers here to help other users. The developes/employees of Mozilla/Firefox rarely, if ever visit here.

Some things to check:

  1. Browsing history must be saved
    • Firefox button: Firefox button > Options > Options > Privacy > [X] Remember my browsing history
    • Menu Bar: Tools > Options > Privacy > [X] Remember my browsing history
  2. Also make sure you do not clear "Browsing History" when using Clear Recent History or when closing Firefox
    • Using Clear Recent History
      • Firefox button: Firefox button > History >Clear Recent History
      • Menu Bar: Tools > Clear Recent History
    • When closing Firefox
  3. Make sure you are not in Private Browsing mode or in permanent Private Browsing mode:
  4. If you have theTab Mix Plusextension, then disable the built-in session restore.

To display the "Save Tabs and Exit" message when closing multiple tabs, you can do the following:

  1. Type about:config in the URL/Location/Address bar and press the Enter key
  2. Accept the warning message (promise to be careful)
  3. The preferences page/list will open
  4. Filter = browser.tabs.warnOnClose
  5. If its value is set to false, double-click on it (in the lower panel) to toggle its value to true
  6. Repeat steps 4 and 5 for these following 3 preferences also:
    • browser.warnOnQuit
    • browser.warnOnRestart
    • browser.showQuitWarning
  7. See:
Read this answer in context 👍 17

All Replies (1)

more options

Chosen Solution

One of the changes in Firefox 4: by default Firefox 4 does not display the "Save Tabs and Exit" warning message when closing multiple tabs, but it can be turned back on by changing some preferences.

  • Saving tabs was not removed from Firefox 4, but it works a bit differently.
  • By default, Firefox 4 will not ask to save tabs, but instead it will always save your tabs on exit unless you are in Private Browsing mode. You can restore them next time by:
    1. clicking Firefox button > History >"Restore Previous Session", or
    2. type about:home in the URL bar and press the Enter key, then press the "Restore Previous Session" button
  • Note: This was a decision by the developers. On this forum, we are all uncompensated volunteers here to help other users. The developes/employees of Mozilla/Firefox rarely, if ever visit here.

Some things to check:

  1. Browsing history must be saved
    • Firefox button: Firefox button > Options > Options > Privacy > [X] Remember my browsing history
    • Menu Bar: Tools > Options > Privacy > [X] Remember my browsing history
  2. Also make sure you do not clear "Browsing History" when using Clear Recent History or when closing Firefox
    • Using Clear Recent History
      • Firefox button: Firefox button > History >Clear Recent History
      • Menu Bar: Tools > Clear Recent History
    • When closing Firefox
  3. Make sure you are not in Private Browsing mode or in permanent Private Browsing mode:
  4. If you have theTab Mix Plusextension, then disable the built-in session restore.

To display the "Save Tabs and Exit" message when closing multiple tabs, you can do the following:

  1. Type about:config in the URL/Location/Address bar and press the Enter key
  2. Accept the warning message (promise to be careful)
  3. The preferences page/list will open
  4. Filter = browser.tabs.warnOnClose
  5. If its value is set to false, double-click on it (in the lower panel) to toggle its value to true
  6. Repeat steps 4 and 5 for these following 3 preferences also:
    • browser.warnOnQuit
    • browser.warnOnRestart
    • browser.showQuitWarning
  7. See: