X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox wont display 90% of the pages I go to, instead it tries to download every page.

Posted

It just started today. I was looking up something for an old game I was playing and every time I tried to go to a website instead of loading the page it would tell me to download. It tried to get me to download yahoo answers, chacha and many other sites. This is annoying and I refuse to download things that don't need to be downloaded. Anyone know how to fix this problem? Oh and in addition to the non loading pages I get a lot of pages the has weird writing telling me that the page I requested has more to another place and everything. But I have never seen this error either.

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • HP Product Detection Plugin
  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Winamp Application Detector
  • Default Plug-in
  • Google Update
  • Pando Web Plugin
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • DivX Web Player version 2.0.3.4
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Nexon Game Controller
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Try "Reset Download Actions"

Question owner

I don't think this will help. All links are leading to untitled download pages instead of the site but if I copy and paste the site it comes up fine. It's not reading the websites correctly. From what my friend said it could be corrupted files in firefox itself. None of the websites require downloading at all. The websites are simple question answer sites like, yahoo answers, chacha, and a few others. That site is talking about actual downloaded file types that are suppose to be downloaded not websites that are suppose to be read.

It's just like this site, it's meant to be read not downloaded.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

You can anyway try to delete or rename mimeTypes.rdf to see if it helps.


You can also check your security software (firewall) and make sure that it isn't restricting Firefox.

Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process.

See:

Question owner

I upgraded to the latest version of firefox though most of my toolbars don't work on it now. It doesn't matter because I seem to have fixed my problem. I guess it was some corrupt files or something but thank you for your help. I will let you know if the problem returns.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

You're welcome