X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I stop the Add-On Bar from showing every time I open Firefox?

Posted

Even though I keep deselecting the Add-On Bar option when I right click on the bar, every time I open Firefox I still see the Add-on bar. Is there a way to keep the Add-On Bar off?

Additional System Details

Installed Plug-ins

  • np-mswmp
  • Coupons, Inc. Coupon Printer Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Shockwave Flash 10.2 r153
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • McAfee Virtual Technician plugin for Mozilla (Gecko Version: 1.8b1)
  • 4.0.60310.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Live Update v1.5
  • NPWLPG
  • Google Update
  • Wacom Dynamic Link Library

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Do you have he McAfee Site Advisor, that extension is known to cause this problem. If you have that one either disable or uninstall it.

If you do not have that extension, you can check to see if another extension is causing this, for details of how to do that see https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

Question owner

I actually have WOT, and I would not like to get rid of it if I don't have to. Is there something I can do to stop the Add-On Bar from showing? Thanks.

grahamt 0 solutions 11 answers

As reported elsewhere a modified version of the Firefox userChrome.css file can be used to prevent the Add-on Bar being launched at Firefox restart. You can find a copy of this code in the file I have posted in my Public folder on Skydrive here: https://skydrive.live.com/?cid=8997700dc0fb2601&sc=documents&uc=1&id=8997700DC0FB2601%21119# This can be downloaded and installed in the Firefox profile chrome folder, alongside the two examples provided by Mozilla.

Hasan 477 solutions 5600 answers

Preferences are not saved

https://support.mozilla.com/en-US/kb/Preferences%20are%20not%20saved

Check and tell if its working.

Macenro 0 solutions 3 answers

IF YOU HAVE FIREBUG INSTALLED!!!!!!!!! Its easy, just open a new tab and type: 'about:config' hit enter and you will be shown a warning if you have not yet disabled it and just click, 'i'll be careful, i promise!' button. Now, in the configuration tab, click to the filter and type: 'addonbar' you'll get a result like this, somewhere: 'extensions.firebug.addonBarOpened' CHANGE THIS TO FALSE. And, you're done. (restart FF)

Modified by Macenro